This forum is in READ-ONLY mode.
You can look around, but if you want to ask a new question, please use the new forum.
Home » plugins » Javascript plugins » PEAR.php error when installing sfJqueryReloadedPlugin-1.4.1
PEAR.php error when installing sfJqueryReloadedPlugin-1.4.1 [message #102832] Wed, 21 July 2010 00:58
jseverson  is currently offline jseverson
Messages: 2
Registered: July 2010
Junior Member
I know this should be super simple, but just want to clarify, does the symfony plugin:install command line utility require PEAR (i think it does)? Or is it the actual plugin I'm installing that requires PEAR? If Symfony requires PEAR for the basic plugin installation process, why doesn't it just come bundled with PEAR? Do I just need to manually download it and stick it into the lib/vendor folder and make sure my include class path points there? Here are my two attempts to install this plugin, and both results in the same error:


Attempt #1 (installing via plugin name):

c:\work\exercise-sym>symfony plugin:install sfJqueryReloadedPlugin
>> plugin installing plugin "sfJqueryReloadedPlugin"
PHP Warning: require_once(PEAR.php): failed to open stream: No such file or directory in C:\work\exercise-sym\lib\vendor\symfony\lib\plugin\sfPearEnv ironment.class.php on line 15

Warning: require_once(PEAR.php): failed to open stream: No such file or directory in C:\work\exercise-sym\lib\vendor\symfony\lib\plugin\sfPearEnv ironment.class.php on line 15
PHP Fatal error: require_once(): Failed opening required 'PEAR.php' (include_path='.;C:\php5\pear') in C:\work\exercise-sym\lib\vendor\symfony\lib\plugin\sfPearEnv ironment.class.php on line 15

Fatal error: require_once(): Failed opening required 'PEAR.php' (include_path='.;C:\php5\pear') in C:\work\exercise-sym\lib\vendor\symfony\lib\plugin\sfPearEnv ironment.class.php on line 15

Attempt #2 (installing via tgz):

c:\work\exercise-sym>symfony plugin:install /work/sfJqueryReloadedPlugin-1.4.1.tgz
>> plugin installing plugin "/work/sfJqueryReloadedPlugin-1.4.1.tgz"
PHP Warning: require_once(PEAR.php): failed to open stream: No such file or directory in C:\work\exercise-sym\lib\vendor\symfony\lib\plugin\sfPearEnv ironment.class.php on line 15

Warning: require_once(PEAR.php): failed to open stream: No such file or directory in C:\work\exercise-sym\lib\vendor\symfony\lib\plugin\sfPearEnv ironment.class.php on line 15
PHP Fatal error: require_once(): Failed opening required 'PEAR.php' (include_path='.;C:\php5\pear') in C:\work\exercise-sym\lib\vendor\symfony\lib\plugin\sfPearEnv ironment.class.php on line 15

Fatal error: require_once(): Failed opening required 'PEAR.php' (include_path='.;C:\php5\pear') in C:\work\exercise-sym\lib\vendor\symfony\lib\plugin\sfPearEnv ironment.class.php on line 15


Previous Topic:[RESOLVED] JQuery TableSorter with Symfony 1.4.6
Goto Forum:
  

powered by FUDforum - copyright ©2001-2004 FUD Forum Bulletin Board Software