This forum is in READ-ONLY mode.
You can look around, but if you want to ask a new question, please use the new forum.
Home » plugins » General plug-ins » sfLESSPlugin absolute path issues
sfLESSPlugin absolute path issues [message #102673] Sat, 17 July 2010 20:07
Dr Fnord  is currently offline Dr Fnord
Messages: 16
Registered: April 2009
Location: Dublin, Ireland
Junior Member
Hello!


I'm trying to use the sfLESSPlugin, and it breaks a bit. When checking the log, I discovered that it couldn't find the lessc file, which turned out to be partly that Apache is run as "nobody" on OS X and thus had access to exactly no commands whatsoever (remedied that, now runs as me). The other part seems to be that PHP requires absolute paths when calling a file! Including lessc!

So I modified the plugin so that it has the absolute path ("/usr/local/bin/lessc" instead of just "lessc"). However, this just moved the problem one step. Now it can't find node.js instead.

Is there any way to make PHP use environment paths to look for files, or to switch off the requirement for absolute paths? This is in dev right now, so security is not a big issue right now.


Cheers,

Henrik
Previous Topic:Task doctrine:generate is not defined
Next Topic:new minify plugin
Goto Forum:
  

powered by FUDforum - copyright ©2001-2004 FUD Forum Bulletin Board Software