This forum is in READ-ONLY mode.
You can look around, but if you want to ask a new question, please use the new forum.
Home » legacy support » symfony 1.0 » Propel 1.5 for Symfony 1.0?
icon14.gif  Propel 1.5 for Symfony 1.0? [message #102423] Tue, 13 July 2010 15:04 Go to next message
halfer  is currently offline halfer
Messages: 9535
Registered: January 2006
Location: West Midlands, UK
Faithful Member
Hi all

As per most of my posts, we are still on symfony 1.0 with the bundled version of Propel, 1.2.x. I think I might have been successful in making the case to upgrade Propel to a more recent version, but the plugin has only been released for the latest versions of symfony.

Has anyone still using 1.0 tried this? Or, would it be fairly straightforward for me to change the tasks back to the old 1.0 approach? Yes, it might be less work in the long run to upgrade immediately to symfony 1.3, but I don't think the business will accept it.

[Updated on: Tue, 13 July 2010 15:07]


Remember Palestine
Re: Propel 1.5 for Symfony 1.0? [message #102454 is a reply to message #102423 ] Wed, 14 July 2010 10:41 Go to previous messageGo to next message
halfer  is currently offline halfer
Messages: 9535
Registered: January 2006
Location: West Midlands, UK
Faithful Member
Hello, it's echoey in here! Very Happy


Remember Palestine
Re: Propel 1.5 for Symfony 1.0? [message #102578 is a reply to message #102423 ] Fri, 16 July 2010 11:25 Go to previous messageGo to next message
halfer  is currently offline halfer
Messages: 9535
Registered: January 2006
Location: West Midlands, UK
Faithful Member
There surely must be a 1.0 user who has upgraded Propel past the beta 1.3 plugin?

If you have sufficient knowledge to answer, please do so. I have helped out on this board for many years, and very rarely do I ask my own questions.


Remember Palestine
Re: Propel 1.5 for Symfony 1.0? [message #102947 is a reply to message #102578 ] Thu, 22 July 2010 16:53 Go to previous messageGo to next message
francois  is currently offline francois
Messages: 1636
Registered: October 2005
Faithful Member
Hi Halfer,

As Propel 1.5 is BC with Propel 1.3, that should theoretically not be harder than upgrading from Propel 1.2 to Propel 1.3 (mostly method name changes in generated Peer classes - see http://www.propelorm.org/wiki/Documentation/1.3/Upgrading).

However, the Propel integration into symfony has gone a long way since 1.0. Routes, Widgets, Form framework, these have all been deeply integrated with the ORM in both sfPropelPlugin for 1.3 and sfPropel15Plugin. Incidentally, that means breaking BC for the 1.0 admin generator, which I think will be a deal breaker for you.
Re: Propel 1.5 for Symfony 1.0? [message #102985 is a reply to message #102423 ] Fri, 23 July 2010 10:42 Go to previous message
halfer  is currently offline halfer
Messages: 9535
Registered: January 2006
Location: West Midlands, UK
Faithful Member
Thanks francois.

I don't use the admin generator, but am increasingly using the module generator, to kickstart development on each new list-detail screen I write. So now that you mention that deep integration, I think you're right.

Thankfully I've been able to lobby successfully to use 1.3 for our latest project, so this will be less of an issue - just got to iron out a few hiccups with Oracle Smile


Remember Palestine
Previous Topic:Warning: Cannot modify header information - headers already sent by
Next Topic:Template not shown in IE 6
Goto Forum:
  

powered by FUDforum - copyright ©2001-2004 FUD Forum Bulletin Board Software