This forum is in READ-ONLY mode.
You can look around, but if you want to ask a new question, please use the new forum.
Home » support » Installation and setup » Cache directory problem, uncaught exception sfCacheException, tried everything nothing works
Cache directory problem, uncaught exception sfCacheException, tried everything nothing works [message #102355] Mon, 12 July 2010 12:27
simani  is currently offline simani
Messages: 1
Registered: July 2010
Junior Member
Hello !

I'm having some troubles setting up my symfony project on Fedora (it worked fine on Ubuntu and Windows, but for some reason I've been asked to work with Fedora). I am getting the cache issue I read about in many topics.

I followed the procedure to create a symfony project to the letter, but when I try to access the project through I get a blank page (even with frontend_dev.php). The Virtual hosts are correcly configured.

The apache error log reports this error :
PHP Fatal error: Uncaught exception 'sfCacheException' with message 'Failed to make cache directory "/var/www/html/mysfproject/cache/frontend/prod/config" while generating cache for configuration file "config/config_handlers.yml"

I've searched all around the internet and this forum but I didn't find a solution. Many people had the same problem but following the same steps did nothing...

I tried setting the permissions recursively to 777 to the cache folder, I tried giving apache the ownership of the folder and subfolders, I tried symfony project:permissions, deleting and creating the folder again (with the 777 permissions), etc., but nothing worked (each time cleaning the cache with symfony cc and restarting apache...)

I tried something else : I manually created the subfolders (frontend/prod/config) and the error changed, it said "failed to open the stream no such file or directory" and "failed opening required ..../config_config_handlers.yml.php"

I've run out of possible solutions to try, and every module and plugin and package is up to date. This far the solutions I've tried worked for everyone else...

Thank you in advance for your help !

(sorry for the english mistakes if there are, I am not english speaking ^^)
Previous Topic:1.2 | Autoload file found, Autoload class not found.
Next Topic:shared host root ready .htaccess
Goto Forum:

powered by FUDforum - copyright ©2001-2004 FUD Forum Bulletin Board Software