This forum is in READ-ONLY mode.
You can look around, but if you want to ask a new question, please use the new forum.
Home » support » Installation and setup » Issues with: Uncaught exception 'InvalidArgumentException' with message 'The plugin "sfGuardPlu
Issues with: Uncaught exception 'InvalidArgumentException' with message 'The plugin "sfGuardPlu [message #101661] Sun, 27 June 2010 00:59 Go to next message
geodev  is currently offline geodev
Messages: 36
Registered: June 2010
Hi there!

my project went smoothly when i decided to install the SfGuardPlugin to begin with security. The installation worked good an i decided then to rebuild my schema but i got the message:

Fatal error: Class 'sfPropelBaseTask' not found in /nfs/http4/geodev/www/sfproject/plugins/sfGuardPlugin/lib/ta sk/sfGuardCreateUserTask.class.php on line 19

SO i decided to uninstall it, but i got the same message again.

After having deleted "manually) with a rm -r I wanted to clean things up with symfony cc and ran into a marvellous:
atal error: Uncaught exception 'InvalidArgumentException' with message 'The plugin "sfGuardPlugin" does not exist.' in /usr/local/alwaysdata/php/symfony/1.4.3/lib/config/sfProject Configuration.class.php:460

Since then, nothing work anymore. Is there something to do to avoid a remake of my project that includes some linecodes Wink

Thanks a lot for your help.

Nb 1: I use doctrine
NB2 I already tried to install the plugin again without much success.

[Updated on: Sun, 27 June 2010 01:00]

Re: Issues with: Uncaught exception 'InvalidArgumentException' with message 'The plugin "sfGuar [message #101708 is a reply to message #101661 ] Mon, 28 June 2010 12:48 Go to previous message
tomor  is currently offline tomor
Messages: 110
Registered: December 2009
Senior Member
Do you have this plugin enabled in ProjectConfiguration.class.php?
If so remove it from there.

Try symfony cc, or clear the cache manually. Then rebuild (symfony doctrine:build --all --and-load --no-confirmation)

For doctrine use sfDoctrineGuardPlugin
Previous Topic:Jobeet erroring out on Day 3 "doctrine:insert-sql"
Next Topic:can someone please explain this HTACCESS code
Goto Forum:

powered by FUDforum - copyright ©2001-2004 FUD Forum Bulletin Board Software