This forum is in READ-ONLY mode.
You can look around, but if you want to ask a new question, please use the new forum.
Home » support » Installation and setup » Problems concerning model main
Problems concerning model main [message #101560] Thu, 24 June 2010 22:34 Go to next message
geodev  is currently offline geodev
Messages: 36
Registered: June 2010
Member
hi everyone! I'm new at symfony and really impatitent to begin with!

I managed to creat a new project, build the schema and my models.

I get a pretty page on my browser telling me Symfony project creted Smile

Nevertheless when i try to access wih my browser to the next step, the model i get the following error message:
Warning: require(/nfs/http4/geodev/www/sfproject/apps/frontend/lib/my User.class.php) [function.require]: failed to open stream: No such file or directory in /usr/local/alwaysdata/php/symfony/1.4.3/lib/autoload/sfAutol oad.class.php on line 188

Fatal error: require() [function.require]: Failed opening required '/nfs/http4/geodev/www/sfproject/apps/frontend/lib/myUser.cl ass.php' (include_path='.:/usr/local/share/php:/usr/lib/php5/pear') in /usr/local/alwaysdata/php/symfony/1.4.3/lib/autoload/sfAutol oad.class.php on line 188

Do you have any idea of what caused this ans how I can go on?

I have also to say that all files and directory are there Laughing

[Updated on: Thu, 24 June 2010 22:35]

Re: Problems concerning model main [message #101564 is a reply to message #101560 ] Thu, 24 June 2010 23:01 Go to previous messageGo to next message
halfer  is currently offline halfer
Messages: 9535
Registered: January 2006
Location: West Midlands, UK
Faithful Member
What permissions user and group permissions are set for "/nfs/http4/geodev/www/sfproject/apps/frontend/lib/ myUser.class.php"?

You may need to use chmod, chown or chgrp so that the file is readable and executable by the user the web server runs under.


Remember Palestine
Re: Problems concerning model main [message #101566 is a reply to message #101564 ] Thu, 24 June 2010 23:11 Go to previous messageGo to next message
geodev  is currently offline geodev
Messages: 36
Registered: June 2010
Member
Thanks for that my friend.

I'm new to linux stuff and symfony forces me to learn what's going on i try a chmod 777 on myuser.php andit works Smile
Re: Problems concerning model main [message #101596 is a reply to message #101560 ] Fri, 25 June 2010 13:03 Go to previous message
halfer  is currently offline halfer
Messages: 9535
Registered: January 2006
Location: West Midlands, UK
Faithful Member
777 may be too generous (i.e. not secure enough) but a forum reply that explains why would run to several pages. I recommend you read up on this topic, so that you give only the bare minimum permissions required.


Remember Palestine
Previous Topic:.htpasswd protection for uploads folder
Next Topic:Jobeet erroring out on Day 3 "doctrine:insert-sql"
Goto Forum:
  

powered by FUDforum - copyright ©2001-2004 FUD Forum Bulletin Board Software