This forum is in READ-ONLY mode.
You can look around, but if you want to ask a new question, please use the new forum.
Home » legacy support » symfony 1.0 » Symfony 1.0.22 sandbox: Rendering stops after Creole connect
Symfony 1.0.22 sandbox: Rendering stops after Creole connect [message #99865] Wed, 26 May 2010 17:56 Go to next message
senordingdong  is currently offline senordingdong
Messages: 1
Registered: May 2010
Junior Member

one of our old applications has stopped working, and i have a hard time figuring out what the heck is causing the problem.

it seems like output rendering is completely stopped after the following log entry:

May 26 17:24:41 symfony [info] {sfCreole} connect(): DSN: array (   'compat_assoc_lower' => NULL,   'compat_rtrim_string' => NULL,   'database' => 'XXX',   'encoding' => NULL,   'hostspec' => 'XXX',   'password' => 'XXX',   'persistent' => NULL,   'phptype' => 'mysql',   'port' => NULL,   'protocol' => NULL,   'socket' => NULL,   'username' => 'XXX', ), FLAGS: 0

there is no error message in web or log, output just stops.

the sql settings are working, i have a mirrored staging system running with the same source and configs (-> connecting to the same database) but different environment, without any problems.

so i assumed that some php.ini values (it's on a shared host) were to blame.
some values were off/conservative, so that should've done the trick:

php_value magic_quotes_gpc 0
php_value error_reporting 1
php_value zend.ze1_compatibility_mode Off
php_value memory_limit 256M

values are interpreted, but it didn't help.

output is fine as long as there is NO connection to database (but ther isnt much sense in that...).

cache has been emptied every time i tried a new fix.
sferrorhandler plugin is also present & working.

i have googled for hours now for similar problems - no success.

has anybody stumbled upon something like that?

env. info:
php 5.2.12

before you ask:
moving it to another host is not an option, sadly

thanks in advance,
Re: Symfony 1.0.22 sandbox: Rendering stops after Creole connect [message #99872 is a reply to message #99865 ] Wed, 26 May 2010 18:55 Go to previous message
halfer  is currently offline halfer
Messages: 9535
Registered: January 2006
Location: West Midlands, UK
Faithful Member
If this has worked before on this host, the host is likely to have changed a configuration setting. Ask them what they did.

See if you get any greater level of error messages if you use your debug front controller, and of course check your php logs.

Remember Palestine
Previous Topic:Clearing specific function cache
Next Topic:Errors after transfering a project from a server to a local server
Goto Forum:

powered by FUDforum - copyright ©2001-2004 FUD Forum Bulletin Board Software