This forum is in READ-ONLY mode.
You can look around, but if you want to ask a new question, please use the new forum.
Home » legacy support » symfony 1.2 » propel:insert-sql doesn't work anymore since php 5.3
propel:insert-sql doesn't work anymore since php 5.3 [message #84464] Thu, 27 August 2009 14:21 Go to next message
Archaon  is currently offline Archaon
Messages: 3
Registered: February 2009
Junior Member
Hi,

Since I upgraded php from 5.2.9 to php 5.3, I have the following problem:


./symfony propel:insert-sql

>> schema    converting "/Users/Archaon/Proj...erver/config/schema.yml" to XML
>> schema    putting /Users/Archaon/Projects...ver/config/generated-schema.xml
>> propel    Running "insert-sql" phing task
Execution of target "insert-sql" failed for the following reason: /usr/local/bin/symfony/1.2/lib/plugins/sfPropelPlugin/lib/vendor/propel-generator/build-propel.xml:275:1:  [wrapped: SQLSTATE[HY000] [2002] No such file or directory]
    [phing] /usr/local/bin/symfony/1.2/lib/plugins/sfPropelPlugin/lib/vendor/propel-generator/build-propel.xml:275:1:  [wrapped: SQLSTATE[HY000] [2002] No such file or directory]
                                                                                                    
  Some problems occurred when executing the task:                                                   
    build-propel.xml:275:1:  [wrapped: SQLSTATE[HY000] [2002] No such file or directory]            
    If the exception message is not clear enough, read the output of the task for more information  
                                                                                                    
>> file-     /Users/Archaon/Projects/Crisis ...ver/config/generated-schema.xml


I checked the version of the required modules : pdo, pdo_mysql, mysql, mysqli but they are alright.
I really don't know what to do...

Thanks

[Updated on: Thu, 27 August 2009 14:25]

Re: propel:insert-sql doesn't work anymore since php 5.3 [message #86460 is a reply to message #84464 ] Sat, 10 October 2009 13:20 Go to previous messageGo to next message
erland  is currently offline erland
Messages: 14
Registered: August 2007
Location: Oslo, Norway
Junior Member
Hi,

I have excactly the same issue. Did you find a solution?

Regards,
Erland
Re: propel:insert-sql doesn't work anymore since php 5.3 [message #86470 is a reply to message #86460 ] Sun, 11 October 2009 17:19 Go to previous messageGo to next message
gabma  is currently offline gabma
Messages: 12
Registered: April 2009
Junior Member
Hi,

Probably the path to the mysql.sock at the

pdo_mysql.default_socket = "/wrong/path/here"


in the php.ini.
Re: propel:insert-sql doesn't work anymore since php 5.3 [message #101919 is a reply to message #84464 ] Fri, 02 July 2010 17:39 Go to previous messageGo to next message
mlapping  is currently offline mlapping
Messages: 2
Registered: July 2010
Junior Member
I ran into this issue running xampp on mac 10.6. My problem was that I was executing the wrong php binary.

Mike$ php symfony propel:insert-sql

would call the php binary in /usr/bin/ not the one in

/Applications/xampp/xamppfiles/bin/ which is what I wanted in the first place. For the same reasons above, the php.ini file for the php installed in /usr/bin/ is lacking the correct settings.

Since I have absolutely no patience to edit the files when I am only learning on this mac, I use the php in xampp

Mike$ /Applications/xampp/xamppfiles/bin/php symfony propel:insert-sql

worked like a charm...

remember that anytime you run a php script from the command line, it will default to using /usr/bin/php, unless you disable or uninstall it.

Thanks for the suggestions

-Mike

Re: propel:insert-sql doesn't work anymore since php 5.3 [message #102322 is a reply to message #101919 ] Sun, 11 July 2010 16:16 Go to previous messageGo to next message
yoann  is currently offline yoann
Messages: 15
Registered: April 2008
Junior Member
Hello Mike !

Go in /usr/bin and rename

php to php_old
phpize to phpize_old
php-config to php-config_old

Then, make symbolic link... :

sudo ln -s /Applications/XAMPP/xamppfiles/bin/php-config php-config
sudo ln -s /Applications/XAMPP/xamppfiles/bin/php php
sudo ln -s /Applications/XAMPP/xamppfiles/bin/phpize phpize

And it's work Wink

Good luck,

Yoann
Re: propel:insert-sql doesn't work anymore since php 5.3 [message #102325 is a reply to message #102322 ] Sun, 11 July 2010 17:40 Go to previous message
mlapping  is currently offline mlapping
Messages: 2
Registered: July 2010
Junior Member
Very nice Yoann, Thank you!

-Mike
Previous Topic:Problem with un-setting of embedded forms in bind()
Next Topic:app.yml parameters in Tasks
Goto Forum:
  

powered by FUDforum - copyright ©2001-2004 FUD Forum Bulletin Board Software