This forum is in READ-ONLY mode.
You can look around, but if you want to ask a new question, please use the new forum.
Home » support » Installation and setup » stuck after installation
stuck after installation [message #79920] Tue, 16 June 2009 10:20 Go to next message
prateek  is currently offline prateek
Messages: 6
Registered: June 2009
Junior Member
hi all,

I installed php 5 and mysql then i downloaded symfony 1.2 archive from website and saved unarchived into c:/inetpub/wwwroot/sfproject/lib/vendor/symfony directory.

I created project and then frontend application. But when i call
http://localhost/sfproject/web/index.php i get a download box where it says to download the file!!!

I am not getting it. Plz help.
I am using internet explorer 8.
Re: stuck after installation [message #79932 is a reply to message #79920 ] Tue, 16 June 2009 13:04 Go to previous messageGo to next message
halfer  is currently offline halfer
Messages: 9535
Registered: January 2006
Location: West Midlands, UK
Faithful Member
You have not set up PHP on your system - this needs to be working first. Manual set up can be tricky if you don't know where to start; read the PHP manual for full details.

If you remain stuck you could try WAMP Server, which loads everything you need already configured:

http://www.wampserver.com/en/


Remember Palestine
Re: stuck after installation [message #79938 is a reply to message #79920 ] Tue, 16 June 2009 13:50 Go to previous messageGo to next message
benhaines  is currently offline benhaines
Messages: 62
Registered: August 2006
Location: London
Member
Or MAMP if you are on a Apple Mac running Leopard...

http://www.benhaines.co.uk/2009/06/06/netbeans-apache-php-xd ebug-and-symfony-on-mac-osx-easy/

I know you aren't on a Mac given your 'c:\' reference... but helpful to others hopefully Wink
Re: stuck after installation [message #79943 is a reply to message #79932 ] Tue, 16 June 2009 14:45 Go to previous messageGo to next message
prateek  is currently offline prateek
Messages: 6
Registered: June 2009
Junior Member
hi,

But i downloaded msi installer for php from http://www.php.net and installed it on my system. It created php directory in program files as well as it shows as an installed component in control panel/Add Remove Programs.

I think it is installed..... should i need to reinstall??
Re: stuck after installation [message #79956 is a reply to message #79943 ] Tue, 16 June 2009 18:56 Go to previous messageGo to next message
DBA_Alex  is currently offline DBA_Alex
Messages: 257
Registered: July 2008
Location: North Carolina, USA
Faithful Member
Do you have a full server stack on your system (Apache, MySQL, PHP)? You'll need to have all of that in order for your symfony app to work.

You can go about this by either installing a pre-built setup like XAMPP, WAMP, etc. or by doing it all yourself.

Here's a link to get you going if you're doing the manual install:
http://www.php-mysql-tutorial.com/wikis/php-tutorial/install ing-php-and-mysql.aspx

I kinda recommend this setup if you regularly update your software. XAMPP and the others don't update to the latest versions of their components for a while after they are released.


Currently Using
---------------------------
Symfony 1.4/Doctrine 1.2
MySQL 5.1
Re: stuck after installation [message #79979 is a reply to message #79920 ] Wed, 17 June 2009 09:42 Go to previous messageGo to next message
prateek  is currently offline prateek
Messages: 6
Registered: June 2009
Junior Member
Ok... Thanks everybody for your replies...

Actually the problem was with IIS server. I had to add .php configuration in properties of default website. Now its working fine. But when i created a new project and application, and tried to access http://localhost/sfproject/web/index.php , i got the following error :-

Fatal error: Uncaught exception 'sfCacheException' with message 'Failed to make cache directory "C:\Inetpub\wwwroot\sfproject\cache\frontend\dev\config" while generating cache for configuration file "config/config_handlers.yml".' in C:\Inetpub\wwwroot\sfproject\lib\vendor\symfony\lib\config\s fConfigCache.class.php:337 Stack trace: #0 C:\Inetpub\wwwroot\sfproject\lib\vendor\symfony\lib\config\s fConfigCache.class.php(107): sfConfigCache->writeCacheFile('config/config_h...', 'C:\Inetpub\wwwr...', '<?php?// auto-g...') #1 C:\Inetpub\wwwroot\sfproject\lib\vendor\symfony\lib\config\s fConfigCache.class.php(194): sfConfigCache->callHandler('config/config_h...', Array, 'C:\Inetpub\wwwr...') #2 C:\Inetpub\wwwroot\sfproject\lib\vendor\symfony\lib\config\s fConfigCache.class.php(276): sfConfigCache->checkConfig('config/config_h...') #3 C:\Inetpub\wwwroot\sfproject\lib\vendor\symfony\lib\config\s fConfigCache.class.php(54): sfConfigCache->loadConfigHandlers() #4 C:\Inetpub\wwwroot\sfproject\lib\vendor\symfony\lib\config\s fConfigCache.cl in C:\Inetpub\wwwroot\sfproject\lib\vendor\symfony\lib\config\s fConfigCache.class.php on line 337


I had setupted symfony in root directory of web server.
Plz help guys...
Re: stuck after installation [message #79991 is a reply to message #79920 ] Wed, 17 June 2009 11:45 Go to previous messageGo to next message
halfer  is currently offline halfer
Messages: 9535
Registered: January 2006
Location: West Midlands, UK
Faithful Member
Hmm, I don't recommend IIS for beginners - it is harder to configure rewrite rules etc. But if you believe you have got it working, OK.

Your key error now is "Failed to make cache directory". I think this means you need to set up permissions on the cache (and log) folders so your server process can write to it. First, try "symfony fix-perms" to see if that solves it (I am not sure it will, on Windows). Failing that, you will need to manually add write permissions for your web server user (the name of which you can get from IIS, I believe).


Remember Palestine
Re: stuck after installation [message #79992 is a reply to message #79943 ] Wed, 17 June 2009 11:48 Go to previous message
halfer  is currently offline halfer
Messages: 9535
Registered: January 2006
Location: West Midlands, UK
Faithful Member
prateek wrote on Tue, 16 June 2009 13:45

But i downloaded msi installer for php from http://www.php.net and installed it on my system. It created php directory in program files as well as it shows as an installed component in control panel/Add Remove Programs.

I think it is installed..... should i need to reinstall??

For the benefit of others, installing PHP using the MSI package will install PHP onto a computer, but (afaik) won't set up your web server correctly. This is mainly because this is best done manually as there are a few choices to make (cgi, fcgid, Apache2 worker, fastcgi etc).


Remember Palestine
Previous Topic:Symfony installation
Next Topic:about symfony install (1.2.7)
Goto Forum:
  

powered by FUDforum - copyright ©2001-2004 FUD Forum Bulletin Board Software