This forum is in READ-ONLY mode.
You can look around, but if you want to ask a new question, please use the new forum.
Home » plugins » Search plugins » SfLucene -> Accented characters
SfLucene -> Accented characters [message #74724] Fri, 13 March 2009 16:50 Go to next message
jb1234  is currently offline jb1234
Messages: 35
Registered: January 2008
Member
Hi All,

After thinking I solved everything with sfLucene, I have another (and hopefully last) issue :

It is the way sfLucene deal with accented character. So I made the following settings :

Config/propel.ini :
propel.database.encoding   = utf8


Config/database.yml :
   encoding:  utf8


Config/search.yml :
  
  index:
    cultures:  [fr, de]
    short_words:  2
    encoding:  UTF-8
    analyser:  utf8num
    case_sensitive: off
    mb_string: on


In the search result page, I don't get accented char, but something like :

"autorités américaines" instead of "autorités américaines".

Using luke, I can see that all the text is stored with encoded accented characters.

Please help, I think I was set everything up.
Re: SfLucene -> Accented characters [message #75166 is a reply to message #74724 ] Thu, 19 March 2009 09:58 Go to previous messageGo to next message
jb1234  is currently offline jb1234
Messages: 35
Registered: January 2008
Member
Hi again,

Nobody faced this issue before ?
Re: SfLucene -> Accented characters [message #82369 is a reply to message #74724 ] Wed, 22 July 2009 21:35 Go to previous messageGo to next message
gearond  is currently offline gearond
Messages: 41
Registered: April 2009
Member
From what I've seen so far, any character encoding issues on the forums seem to be ignored, mostly.

Let me know what you come up with, OK? I don't have anything to help, but I am very interested in setting up my new project to be completely language neutral.
Re: SfLucene -> Accented characters [message #83123 is a reply to message #82369 ] Tue, 04 August 2009 07:20 Go to previous message
Panchulo  is currently offline Panchulo
Messages: 59
Registered: November 2008
Location: Chile
Member
One thing that worked for me recently was to change the Encoding of the files to UTF-8.

Recently I was having problems with some fixtures files, I couldn't get spanish to work, even though I configured everything in symfony to UTF-8.

Check on your IDEs Preferences and set the Default Encoding to UTF-8. Check the files as well like I said before.
Previous Topic:[solved] The search engine work in frontend_dev.php but not in production
Next Topic:Searching for more than 1 model with Zend Search
Goto Forum:
  

powered by FUDforum - copyright ©2001-2004 FUD Forum Bulletin Board Software