This forum is in READ-ONLY mode.
You can look around, but if you want to ask a new question, please use the new forum.
Home » plugins » Javascript plugins » FCKeditor not working after deploying project
FCKeditor not working after deploying project [message #53620] Fri, 06 June 2008 23:18 Go to next message
boteeka  is currently offline boteeka
Messages: 19
Registered: January 2008
Location: Romania
Junior Member
Hi everybody!

I have a problem with FCKeditor. It works locally, but when I deploy my project to the server (using freeze and ftp upload) it stops working. It keeps giving me the sfConfigurationException error, and telling me "You must install FCKEditor to use this helper (see rich_text_fck_js_dir settings).". But this is already installed and the config files are OK too.

The problem is strange, because it worked before, and I've done everything the same way now too.

Please help.
Re: FCKeditor not working after deploying project [message #53720 is a reply to message #53620 ] Mon, 09 June 2008 17:00 Go to previous messageGo to next message
boteeka  is currently offline boteeka
Messages: 19
Registered: January 2008
Location: Romania
Junior Member
Nobody encountered this problem?

Please help if you have any ideas.
icon4.gif  Re: FCKeditor not working after deploying project [message #55725 is a reply to message #53620 ] Tue, 08 July 2008 13:09 Go to previous messageGo to next message
tim0t  is currently offline tim0t
Messages: 1
Registered: July 2008
Junior Member
I have the same problem with the FCKEditor.

When I deploy the project on a shared host environment I get the same error as described above.

My server directory listing looks like this:

/apps
/cache
/config
/data
/lib
/log
/logs
/website.eu
**/css
**/images
**/js
****/fckeditor
**/sf
**/uploads
**index & dev files
/plugins

I allready tried the following things in the settings.yml file:

1. js/fckeditor/

2. website.eu/js/fckeditor

3. Set the path to document root home/users/websiteeuftp/website.eu/js/fckeditor

They all give the same error:

"500 Internal Server Error" and "[sfConfigurationException]
You must install FCKEditor to use this helper (see rich_text_fck_js_dir settings)"

Does anyone know the answer? I'm searching for it a long time now.
Re: FCKeditor not working after deploying project [message #61500 is a reply to message #55725 ] Mon, 22 September 2008 12:24 Go to previous messageGo to next message
ads1  is currently offline ads1
Messages: 5
Registered: July 2008
Junior Member
Hi,

Please somebody help Smile I also have this problem with a 'frozen' project on shared hosting. I can't for the life of me get FCK working...

Re: FCKeditor not working after deploying project [message #64606 is a reply to message #61500 ] Thu, 06 November 2008 01:29 Go to previous messageGo to next message
kocmat  is currently offline kocmat
Messages: 3
Registered: October 2007
Junior Member
Hey, I've just found your posts. Had the same troubles tonight.

If you had not moved to ruby, here is your solution:
Move the rich_text_fck_js_dir: js/fckeditor setting from dev:, or wherever you put it to all: section in <your_app>/settings.yml
Re: FCKeditor not working after deploying project [message #68655 is a reply to message #53620 ] Sat, 27 December 2008 01:24 Go to previous messageGo to next message
thenthdoctor  is currently offline thenthdoctor
Messages: 3
Registered: September 2007
Location: Akron, OH
Junior Member
I had this problem and fixed it for my own case.

I had a custom web folder and in the interim between my FCK working and not working, I upgraded to a newer Symfony.

I checked the toolbar's Vars & Config section, and found that my sf_web_dir had gotten "/../web" tacked on to the end of it.

I created a symlink from web/ to my actual web basedir and suddenly, FCK was working again.

In the meantime, I did a ton of grepping and changing folder names throughout the various config files under js/fckeditor to update the new location, but it was the symlink that finally fixed it.

[Updated on: Sat, 27 December 2008 01:25]

Re: FCKeditor not working after deploying project [message #76691 is a reply to message #68655 ] Sat, 11 April 2009 22:08 Go to previous messageGo to next message
jepsilon  is currently offline jepsilon
Messages: 2
Registered: February 2008
Location: Caracas, Venezuela
Junior Member
Hi may you explain a little how you do the symlinks , i have the same problem ...
Re: FCKeditor not working after deploying project [message #85720 is a reply to message #76691 ] Thu, 24 September 2009 13:17 Go to previous message
deva.symfony  is currently offline deva.symfony
Messages: 47
Registered: February 2009
Location: chennai
Member
Go your apps , example admin->config->settings.yml
and see like this,when you want to add fckeditor i put bold font in below.like that you have to put.youe will get answer

prod:
.settings:
no_script_name: on
logging_enabled: off

dev:
.settings:
error_reporting: <?php echo (E_ALL | E_STRICT)."\n" ?>
web_debug: on
cache: off
no_script_name: off
etag: off
rich_text_fck_js_dir: js/fckeditor

--------------------------------



then you put into your template:
ex:
AddSuccess.php

<?php $options = array('rich' => 'fck','height' => 500,'width' => 700,'config'=>'fckeditor/fckeditor.js');
echo textarea_tag('PageContent','', $options ); ?>
Previous Topic:update_element_function problem: position parameter does not work
Next Topic:sfLightWindowPlugin: where i should define the size of a modal window?
Goto Forum:
  

powered by FUDforum - copyright ©2001-2004 FUD Forum Bulletin Board Software