This forum is in READ-ONLY mode.
You can look around, but if you want to ask a new question, please use the new forum.
Today's Messages (OFF)  | Unanswered Messages (ON)

Forum: snipeet
 Topic: table prefix and phpName in schema.xml
table prefix and phpName in schema.xml [message #53529] Thu, 05 June 2008 13:25
simo  is currently offline simo
Messages: 41
Registered: May 2008
Location: Paris
Hi all,

I wrote few lines of code to remove table prefix and automatically provides phpName attribute to tables on schema.xml file, respecting the CamelCase format.

You just have to provide the prefix, the source xml file and the generated xml file (if different - not compulsory).

$prefix = 'prefix_';
$filePath = 'way\to\your\xml\file';
$fileSave = 'way\to\the\generated\xml\file'; # not compulsory

function removePrefix ($string) {
  $prefix = $GLOBALS['prefix'];

  $string = str_replace($prefix, '', $string);
  $arr = split('_', $string);
  $name = '';
  foreach($arr as $row) {
    $name .= ucfirst($row);

  return $name;


if (file_exists($filePath)) {

  $xml =simplexml_load_file($filePath);

  foreach($xml->xpath('//table') as $item) {
    $attrs = $item->attributes();
    $phpName = removePrefix ($attrs['name']);
    $item->addAttribute('phpName', $phpName);

  if(isset($fileSave) && $fileSave != '') {
    $xmlFile = $fileSave;
  } else {
    $xmlFile = $filePath;

} else {
  exit('Failed to open file : '. $filePath);

Hope i'm not re-inventing the wheel and it will be usefull to you!

I guess the message has to be switched to another category.. sorry for that.

[Updated on: Thu, 05 June 2008 13:30]

 Topic: click on "user" link in comment section throws 404
icon4.gif  click on "user" link in comment section throws 404 [message #60751] Thu, 11 September 2008 11:48
kpprasad  is currently offline kpprasad
Messages: 1
Registered: August 2008
Junior Member

When user doesnt have any snippet associated with his user_id and if the user creates a comment and click on the user link available in the comment section it throws 404.

1. create a new user.
2. add comment to any snippet and now click on the user name in comment section.
[note: the new user should not have any snippet associated with his user_id.]

Let me know how to fix it.
Thanks in advance

[Updated on: Thu, 11 September 2008 11:52]

Forum: Other
 Topic: New website using Symfony
New website using Symfony [message #49475] Tue, 08 April 2008 18:32
rickb  is currently offline rickb
Messages: 61
Registered: July 2007
Location: Hampshire, UK
I released the first version of my new Symfony-based website at the weekend:

It uses

- this has been great 'out of the box'

- I have revised this substantially and I plan to release my revised version

- likewise, I have revised this substantially and I plan to release my revised version

Other plugins include sfGuardPlugin, sfOpenIDPlugin, sfFeed2Plugin, sfMediaLibraryPlugin, sfPrototypePlugin, sfPropelAlternativeSchemaPlugin, sfPropelActAsNestedSetBehaviorPlugin, and sfCombineFilterPlugin (planned but not yet in use)

I'm also using Mootools, which I prefer over Prototype.

I wrote a "plugin-like" feature that is similar to the sfSimpleNewsPlugin and provides sidebar blocks containing news, teasers etc. As with my modified sfSimpleNewsPlugin, blocks can appear and disappear on calendar dates. Unlike sfSimpleNewsPlugin it supports I18n. I have been wondering whether it would actually be possible to merge sfSimpleNewsPlugin and my sidebar block module to make a single plugin that would handle date-constrained CMS news content. Just a thought at this stage.

[Updated on: Tue, 08 April 2008 18:32]

 Topic: Contributing in Symfony Wiki
Contributing in Symfony Wiki [message #50206] Thu, 17 April 2008 14:20
lukaswoj  is currently offline lukaswoj
Messages: 6
Registered: May 2007
Junior Member

I have suggestions about one of the Wiki Pages:

I'm not sure what should I do.
Should I try to contact author of that Page or should I just Edit that Page and change what I think is wrong ?

Best regards
Łukasz Wojciechowski
 Topic: php action links passing javascript (jquery) generated variables
php action links passing javascript (jquery) generated variables [message #56250] Tue, 15 July 2008 18:10
tatanajllo  is currently offline tatanajllo
Messages: 13
Registered: July 2008
Junior Member
Hi I really need your expertise on this.

I'm trying to link to an action but before going to the action I need to get the variables from a javascript.

To better explain:

in my module success:

<div class = 'navigation_select'><a onClick="createadNzone()" href="#">Create</a></div>

in my .js file:

function createadNzone()
var load_week = $("#navigation_week").selectedValues();

type: "POST",
URL: "/navigation/addadNzones",
data: "load_week="+load_week+""


in my action:

public function executeAddadNzones($request)

$newAdhere = new Ad();


Nothing is happening here the ajax does post the values, but it does not redirect to the action... it stays the current page loaded.

Pls help.

 Topic: Securing a TinyMce Plugin called TinyBrowser
Securing a TinyMce Plugin called TinyBrowser [message #64660] Thu, 06 November 2008 15:45
eljwc  is currently offline eljwc
Messages: 130
Registered: November 2006
Location: UK
Senior Member
I've started using TinyBrowser d.php
for TinyMCE image/file browsing its ace and is well worth a look!

I've bee trying to work out how I'm going to secure it. The best option would be from Symfony, but how could that be accomplished? I could use .htaccess but the user would have to log in twice.

All the files live under the TinyMCE plugin fokder.

Any ideas?

[Updated on: Thu, 06 November 2008 16:09]

John Cleveley
 Topic: Hebergement projet symfony
Hebergement projet symfony [message #96812] Mon, 05 April 2010 18:36
walid  is currently offline walid
Messages: 1
Registered: April 2010
Junior Member
je suis debutant avec symfony, j'ai réalisé une petite application avec frontend et backend, tout se passe bien sur ma machine local.
mon problème est que lorsquej'ai fait l'hébergement sur un serveur distant il me retourne une page blanche sans aucune erreur (index.php).
comment héberger un site web développer avec symfony?
Merci de me répondre Embarassed
 Topic: New (german) site running on Symfony 1.4 -
New (german) site running on Symfony 1.4 - [message #98017] Sun, 25 April 2010 21:49
bigswede  is currently offline bigswede
Messages: 4
Registered: May 2009
Location: Germany
Junior Member

I love Symfony and i just released a general objekt review site.
Off course looks like a Cafe review site, but that's
only on the surface...

I used:
- Symfony 1.4
- Doctrine
- Google local search API
- Google Maps API (encapsulated in a PHP-Class)
- YAML für the Layout (

I call this "single branch review" and i find this more user friendly than
those mamoth sites where you can review almost everything.

What do you think?

 Topic: Job Post - Theming and Extending SteerCMS
Job Post - Theming and Extending SteerCMS [message #98956] Wed, 12 May 2010 18:56
morrillt79  is currently offline morrillt79
Messages: 2
Registered: May 2010
Location: Buenos Aires
Junior Member

I am working on extending and theming steercms.

Screenshots are built, slicers are on standby, looking for the dev team to engage a long term employee relationship.

If you have time, are passionabout symfony, and play well with others, contact me with some work examples, and rate requirements.

I currently have the job posted to odesk:

Forum: askeet
 Topic: Day 7 available
icon1.gif  Day 7 available [message #906] Wed, 07 December 2005 10:45
francois  is currently offline francois
Messages: 1636
Registered: October 2005
Faithful Member
Here is the link:

[Updated on: Thu, 08 December 2005 10:23]

 Topic: Day 8 Available: AJAX and symfony
Day 8 Available: AJAX and symfony [message #925] Thu, 08 December 2005 10:23
francois  is currently offline francois
Messages: 1636
Registered: October 2005
Faithful Member
Here is the link:

[Updated on: Mon, 12 December 2005 15:01]

 Topic: Day 12 available: emails
Day 12 available: emails [message #1043] Mon, 12 December 2005 15:02
francois  is currently offline francois
Messages: 1636
Registered: October 2005
Faithful Member
Here is the link:

[Updated on: Wed, 14 December 2005 16:51]

 Topic: suggestions
suggestions [message #1065] Tue, 13 December 2005 01:04
kappe  is currently offline kappe
Messages: 22
Registered: December 2005
Junior Member
it could be interesting to explain symfony interactions with external libraries (for example dynamic generation of pdf files or graphs).
It could be useful to improve user experience with AJAX (graphs or pdf generation with progress bar during computation and so on).

Thanks for your great job!
 Topic: Day 13 and 14 available: Tags
Day 13 and 14 available: Tags [message #1113] Wed, 14 December 2005 16:52
francois  is currently offline francois
Messages: 1636
Registered: October 2005
Faithful Member
Here are the links:

[Updated on: Thu, 15 December 2005 11:06]

 Topic: Day 15 available: unit tests
Day 15 available: unit tests [message #1131] Thu, 15 December 2005 11:06
francois  is currently offline francois
Messages: 1636
Registered: October 2005
Faithful Member
Here is the link:

[Updated on: Fri, 16 December 2005 13:39]

 Topic: Day 12 - mail content_type
Day 12 - mail content_type [message #2054] Tue, 24 January 2006 15:12
m.wrobel  is currently offline m.wrobel
Messages: 10
Registered: January 2006
Junior Member
How can i set proper content-type of mail parts?

now i get:
1. for html:
Content-Type: text/plain; charset = "iso-8859-1"

2. for plain:
Content-Type: text/trunk/frontend/modules/mail/templates/sendPasswordSucce ss.altbody; name="file1"

i tried (in frontend/modules/mail/config/mailer.yml):

  deliver:    off

  mailer:     sendmail
    content_type:    text/html
    charset:         utf-8
    encoding:        8bit

but it did not work Sad

Mirosław Wróbel
 Topic: Day 4 pushed things (my brain) a bit...
Day 4 pushed things (my brain) a bit... [message #2293] Tue, 31 January 2006 20:09
gags  is currently offline gags
Messages: 2
Registered: January 2006
Junior Member
Hello hello,

I am slowly working through the askeet tutorial, an hour after work - here and there.

I have been working as a php coder for some time but I have to admit that day 4 was quite a challenge. I have got it working but I cannot admit I was totally on top of everything.

All good and fine until

Now that you understand how to modify the model, you can exercise on this and

...I was also not guessing any ideas like

Luckily, we do have a way to test this modification, and you will discover it later in this part - that is, if you haven't guessed it already.

Perhaps I am a middle weight and this is a heavy weight structure, perhaps I just don't know enough about patterns or OO.

Maybe I should just grin and bear it and things will become clearer over the next few days.

Does anyone have any suggestions, or resources, that they can suggest for me - and I am sure loads of middle weight coders - trying to bootstap themselves into frameworks after work - that supplements the ideas being discussed here?


 Topic: Build-SQL Problem
Build-SQL Problem [message #2307] Wed, 01 February 2006 10:56
rawneus  is currently offline rawneus
Messages: 1
Registered: February 2006
Location: Raleigh, NC
Junior Member
I installed WAMP5 on my local XP box to test out various frameworks for my linux production server, Symfony is one of many, and thus far is looking extremely promising.

The tutorials are all aimed mostly for linux, though, so I've had to wage some battles to get some things to work. I'm also double dosing on the learning with the Subversioning system, very nice touch.

On Day 2 I ran into a problem with build-sql. I copied symfony.bat into my Askeet project folder and edited it to hardcore the path back to its home path so that it would work and I could still run it from the project directory. Every command thus far has worked fine except build-sql. For some reason, it tries to find the schema.xml file in


instead of the config folder under the project folder.

Can anyone explain why or what I can do to fix this? I really want to get into the meat of this framework but things like this are starting to get aggravating. :\




D:\SVN\askeet\trunk>symfony build-sql
Buildfile: I:\wamp\php\PEAR\data\symfony\bin\build.xml

sf > build-sql:
[phing] Calling Buildfile 'I:\wamp\php\pear\symfony\propel-generator\build.x
ml' with target 'sql'

propel-project-builder > projectcheck:

propel-project-builder > configure:
[echo] Loading project-specific props from D:\SVN\askeet\trunk/config/build

propel-project-builder > sql:
[phing] Calling Buildfile 'I:\wamp\php\pear\symfony\propel-generator\build-p
ropel.xml' with target 'sql'

propel > check-run-only-on-schema-change:

propel > sql-check:

propel > sql:
[echo] +------------------------------------------+
[echo] | |
[echo] | Generating SQL for YOUR Propel project! |
[echo] | |
[echo] +------------------------------------------+
[phingcall] Calling Buildfile 'I:\wamp\php\pear\symfony\propel-generator\build-p
ropel.xml' with target 'sql-template'

propel > sql-template:
Execution of target "sql-template" failed for the following reason: I:\wamp\php\
pear\symfony\propel-generator\build-propel.xml:150:1: Directory I:\wamp\php\conf
ig not found.
[phingcall] I:\wamp\php\pear\symfony\propel-generator\build-propel.xml:1 50:1: Di
rectory I:\wamp\php\config not found.


Total time: 1.8019 second
 Topic: List of Feature Requests (Please let us know the plan)
List of Feature Requests (Please let us know the plan) [message #2891] Sat, 18 February 2006 00:03
mayous2004  is currently offline mayous2004
Messages: 8
Registered: February 2006
Junior Member
Hi ,
Thanks for the great stuff.. we are planning to deploy for one of our initiatives. I am a new bee.. so please execuse me in case if these questions Smile are already asked...

I have few enhancement requests.. please let me know whats the feasability and time lines in terms of having them in place..

1. We need Tree like categorization and possibly sorting of tags.
2. Ability to post a question to askeet over email
3. Ability to have my Questions in addition most popular
4. Ability to subscribe to a question and get answers only for that question in an email or a feed for a particular question and answer.
5.Ability to asssosiate a image with a question?
6.Ability to include ad-space (classified) space in the askeet
7. Ability to add the questions into something like "My FAQ" something like book marking favourite questions...
8.Ability to create a question (URL) and having them answered through frens without having to login
9.Ability to create Survey based questions? like who will win the superbowl? and turn into a nice looking graph...

Thanks and looking forward to hear from you...
 Topic: Day 7, problem with recent answers
Day 7, problem with recent answers [message #2907] Sun, 19 February 2006 08:13
ropic  is currently offline ropic
Messages: 20
Registered: February 2006
Junior Member
I cannot see the newest answer which has relevancy.

Only if i use a number greater than total registers:

$pager = new sfPropelPager('Answer', 10);

but with

$pager = new sfPropelPager('Answer', sfConfig::get('app_pager_homepage_max'));

i get in first page:

0% UP 0 % DOWN posted by Fabien Potencier on Feb 18, 2006
Don't bring her to a doghnuts shop. Ever. Girls don't like to be seen eating with their fingers - although it's nice.
0% UP 0 % DOWN posted by Fabien Potencier on Feb 18, 2006
The answer is in the question: buy her a step, so she can get some exercise and be grateful for the weight she will lose.

in second page

0% UP 0 % DOWN posted by Fabien Potencier on Feb 18, 2006
The answer is in the question: buy her a step, so she can get some exercise and be grateful for the weight she will lose.
0% UP 0 % DOWN posted by Fabien Potencier on Feb 18, 2006
Build it with symfony - and people will love it.


The answer is in the question: buy her a step, so she can get some exercise and be grateful for the weight she will lose.


Do you know the problem ???

 Topic: day 1 problem
day 1 problem [message #4353] Tue, 28 March 2006 06:52
pliersn  is currently offline pliersn
Messages: 1
Registered: March 2006
Junior Member

I try to make my askeet link like (http://localhost/askeet), so I put this code in httpd.conf

Alias /askeet D:/An/askeet/web
Alias /sf C:/PHP/PEAR/data/symfony/web/sf

<Directory "D:/An/askeet/web">
   AllowOverride All

and edit the askeet/web/.htaccess file like this

Options +FollowSymLinks +ExecCGI

<IfModule mod_rewrite.c>
  RewriteEngine On

  # we skip all files with .something
  RewriteCond %{REQUEST_URI} \..+$
  RewriteCond %{REQUEST_URI} !\.html$
  RewriteRule .* - [L]

  # we check if the .html version is here (caching)
  RewriteRule ^$ index.html [QSA]
  RewriteRule ^([^.]+)$ $1.html [QSA]
  RewriteCond %{REQUEST_FILENAME} !-f

  # no, so we redirect to our front web controller
  RewriteRule ^(.*)$ /askeet/index.php [QSA,L]

# big crash from our front web controller
ErrorDocument 500 "<h2>Application error</h2>symfony application failed to start properly"

The link http://localhost/askeet is ok but the link http://localhost/askeet/frontend_dev.php/ is not. Some css files were boken. This is some lines in its HTML code:

<link rel="stylesheet" type="text/css" media="screen" href="askeet/web/css/askeet/web/sf/css/sf_debug_stats/main.css" />
<link rel="stylesheet" type="text/css" media="screen" href="askeet/web/css/askeet/web/css/main.css" />
<script type="text/javascript" src="askeet/web/js/askeet/web/sf/js/prototype/prototype.js"></script>

How to fix this error?


P.S: Sorry for my English
 Topic: 404 Error with mod_rewrite uncommented
404 Error with mod_rewrite uncommented [message #4553] Sun, 02 April 2006 00:35
jsghagan  is currently offline jsghagan
Messages: 31
Registered: February 2006
On Day 2, I am getting a 404 error on http://askeet/question. I've read through a number posts in this forum in which people have fixed the problem by uncommenting in httpd.conf. This file is uncommented in my httpd.conf and there is the appropriate .htacess file in the askeet/web directory. Has anyone found any other issues that could be causing this? I am running xampp 1.5.1 on a latest gentoo release.
 Topic: Day 4 : timeout with load_data.php
Day 4 : timeout with load_data.php [message #5271] Thu, 20 April 2006 23:18
demental  is currently offline demental
Messages: 34
Registered: April 2006
Location: tarn

This tutorial is just great !

But I'm stuck with transactions in the day 4.

When I
php load_data.php

after adding transaction handling in interests and relevancy save() methods, I have this error :

Fatal error: Uncaught exception 'PropelException' with message 'Unable to execute INSERT statement. [wrapped: Could not execute update [Native Error: Lock wait timeout exceeded; try restarting transaction] [User Info: INSERT INTO ask_interest (QUESTION_ID,USER_ID,CREATED_AT) VALUES (16,29,'2006-04-20 23:09:22')]]' in /Applications/MAMP/bin/php5/lib/php/symfony/vendor/propel/util/BasePeer.php:308
Stack trace:
#0 /Library/WebServer/Documents/symfony_proj/askeet/lib/model/om/BaseInterestPeer.php(904): BasePeer::doInsert(Object(Criteria), Object(sfDebugConnection))
#1 /Library/WebServer/Documents/symfony_proj/askeet/lib/model/om/BaseInterest.php(334): BaseInterestPeer::doInsert(Object(Interest), Object(sfDebugConnection))
#2 /Library/WebServer/Documents/symfony_proj/askeet/lib/model/om/BaseInterest.php(284): BaseInterest->doSave(Object(sfDebugConnection))
#3 /Library/WebServer/Documents/symfony_proj/askeet/lib/model/Interest.php(27): BaseInterest->save(Object(sfDebugConnection))
#4 /Applications/MAMP/bin/php5/lib/php/symfony/ in /Applications/MAMP/bin/php5/lib/php/symfony/vendor/propel/util/BasePeer.php on line 308

This is quite surprising as I don't see where any of the queries sent to the database when inserting and interest or a relevancy need to wait for another to be commited, as :

- The transaction begins
- the interest row is saved
- the question row is read
- the question row is updated
- the transaction is commited

When I switch back to basic save, without transaction, it works ok...

Have someone had the same pb and found a workaround ?
 Topic: Polish Translation proposal.
Polish Translation proposal. [message #5712] Wed, 03 May 2006 19:06
kiwigips  is currently offline kiwigips
Messages: 2
Registered: May 2006
Junior Member
I would be willing to translate the askeet tutorials into Polish. Can you send me the markdown?
 Topic: form validation: date
form validation: date [message #6571] Wed, 24 May 2006 02:49
Messages: 2
Registered: May 2006
Location: Philippines
Junior Member

i'm having a problem on validation a date field. i've tried the sfRegexValidator and entered a regular expression to check the date, but it still doesn't work.does anyone here knows how?
 Topic: QUERY_STRING error in sfWebRequest.class.php
QUERY_STRING error in sfWebRequest.class.php [message #6627] Thu, 25 May 2006 05:32
horst  is currently offline horst
Messages: 13
Registered: May 2006
Junior Member
Whoops, taking this to the Installation and setup forum.

[Updated on: Thu, 25 May 2006 05:36]

 Topic: creole error after ugrade to beta (0.7.1369)
creole error after ugrade to beta (0.7.1369) [message #6679] Fri, 26 May 2006 09:36
hulvat  is currently offline hulvat
Messages: 10
Registered: March 2006
Location: Slovakia
Junior Member
Hi all,

I just upgraded from stable to beta, and my existing symfony code crashed out with the following error:
Warning: oci_execute() [function.oci-execute]: ORA-00907: mising right parenthesis in/usr/share/php/symfony/vendor/creole/drivers/oracle/OCI8PreparedStatement.php on line 117

Fatal error: Call to undefined method sfDebugConnection::nativeError() in /usr/share/php/symfony/vendor/creole/drivers/oracle/OCI8PreparedStatement.php on line 119

in symfony 0.6.2 is all ok, but in beta become i this error.
Creole last change is 4 months ago, so i think the problem is not her.

Is this bug or ?
Thank you for any solution.
 Topic: Physical version of the book?
Physical version of the book? [message #8532] Mon, 10 July 2006 05:38
marckohlbrugge  is currently offline marckohlbrugge
Messages: 164
Registered: January 2006
Senior Member

I think it would be really helpfull to see a physical version of the Askeet tutorials. As most people I only have one screen and I don't like switching between applications when coding.

So I was thinking of printing it, but I think that's as expensive as buying something similar online so I thought it would be nice to be able to buy a physical version of the book. Maybe with some donation costs built-in.

I would happily spend $20 - $30 for a printed book with both the askeet tutorial, the current documentation and askeet on a disc. (just to make it complete, I know the website will always have the most current release) Add some kind of plastic Symfony cheat sheet and I think a lot of developers will be interested.

What do you think?
 Topic: Day 2 - may not be NULL
Day 2 - may not be NULL [message #9061] Thu, 20 July 2006 05:08
purephase  is currently offline purephase
Messages: 2
Registered: July 2006
Junior Member
I'm using the latest symfony beta (0.7.1587) and SQLite (not MySQL) and everything went fine until I tried to create the first question. On /question I get an Internal Server error and on the frontend_dev I get the following error message:

Unable to execute INSERT statement. [wrapped: Could not execute update [Native Error: may not be NULL] [User Info: INSERT INTO ask_question (TITLE,BODY,CREATED_AT,UPDATED_AT) VALUES ('this is a test','test','2006-07-19 22:48:26','2006-07-19 22:48:26')]]

It looks like the auto increment on the id field is not working with SQLite. Anyone else experience this problem? I'd rather not install MySQL on this workstation in order to go through these tutorials. Any help would be appreciated. Thanks.
 Topic: PhingFile not found
PhingFile not found [message #10677] Tue, 22 August 2006 15:10
jatin_svs  is currently offline jatin_svs
Messages: 1
Registered: August 2006
Location: India
Junior Member

I have tried symfony it's great lol

But Now im phasing one problem while Im trying to buliding schema.xml using its command called.
"symfony propel-build-schema" It is displaying me error like

Fatal error: Class 'PhingFile' not found in /usr/share/pear/symfony/vendor/propel-generator/classes/prop el/phing/PropelCreoleTransformTask.php on line 281 If anyone of you are able to reply about this please do that I appreciate your reply.

Thanks a lot in advance

 Topic: Object_input_tag not displaying value
Object_input_tag not displaying value [message #11920] Tue, 12 September 2006 06:47
prasadkarri  is currently offline prasadkarri
Messages: 69
Registered: April 2006
Location: INDIA


echo object_input_tag($vO,'getName');

not displaying the value in the text field

but when i echo the same $vO->getName(); it displays the name

and when i use input_hidden_tag() it is storing the data in hidden field.

please let me know what might went wrong.

 Topic: Where is the right version of askeet working on version 0.7 of symfony?
Where is the right version of askeet working on version 0.7 of symfony? [message #12182] Fri, 15 September 2006 15:11
mlier  is currently offline mlier
Messages: 101
Registered: May 2006
Senior Member
Any idea ?
 Topic: Askeet-Installation with Alias, wrong image-path in CSS-File
Askeet-Installation with Alias, wrong image-path in CSS-File [message #14608] Wed, 25 October 2006 12:30
markus  is currently offline markus
Messages: 4
Registered: October 2006
Junior Member
I tried to install latest SVN-Askeet with Symfony-stable, but I got the following problem:

If i install askeet as a virtual-host-application, then all gets fine.

If i install askeet with an Alias (/askeet/) then the browser can not find the pictures used in the CSS-file, because they are of course not pointing to the correct place.

Dirty solution: change all CSS-/images/-Links to /askeet/images/-Link

I also can not use helper-funtions, because the browser loads the CSS-File without PHP-interaction.

Do you have a solution?
 Topic: Day 3 : column nickname
Day 3 : column nickname [message #14746] Thu, 26 October 2006 23:21
onanga  is currently offline onanga
Messages: 66
Registered: October 2006
Location: France
That day 3 error (when calling load_data.php) is in fact caused by day 2 issue.

If you have this error it's because you build the data structure straight in the database or through YML, but based on the graphic schema representing the database structure.

The error is simply due to the missing column called 'nickname' in the user table. So just add a 'nickname' column in your DB or if you made a YML, add this in 'user:' section :
nickname: varchar(50)

Of course, you should rebuild your model and sql, and insert into database Razz

If you made the whole thing copying/pasting from the XML lines shown, you shouldn't get the error as the field exists in there.


[Updated on: Thu, 26 October 2006 23:22]

Particules, Blog
 Topic: sfFeed Not Found In: Day 11 Problem
sfFeed Not Found In: Day 11 Problem [message #15475] Mon, 06 November 2006 21:53
Messages: 162
Registered: October 2006
Senior Member
I am getting the following error. I have installed the sfFeed as a global pluging. This is the error I am getting:
Fatal error: Class 'sfFeed' not found in /home/me/askeet/apps/frontend/modules/feed/actions/actions.class.php on line 29

Line 29 is this in public function executePopular() of feed module.
$feed = sfFeed::newInstance('rss201rev2');

 Topic: commenting system bug
icon9.gif  commenting system bug [message #15637] Thu, 09 November 2006 12:42
funaki  is currently offline funaki
Messages: 5
Registered: November 2006
Junior Member

I found a problem on askeet commenting system.
When I post a comment it does not work at below page's "add a comment" form.

The details are as follows: oto=15628

 Topic: day2 - propel-build-model
day2 - propel-build-model [message #16948] Thu, 30 November 2006 22:45
Messages: 3
Registered: November 2006
Junior Member
HI, everything going well until this point.
symfony v 06...
I copied the schema to config/schema.xml.
I ran symfony propel-build-model

no files created in lib/model or lib/model/om - in fact om did not exist fromoriginal build so I added it, still not working.

goes through a verbose process with no errors.
No files created. it does create a propelini------ file in config - looks like somekind of dup of propel.ini (creates a new file everytime i run the propel command) I deleted all the propelini----- files and ran it again.
Still no files....

what to look for?

 Topic: Day 6: POSTDATA has expired from cache
icon9.gif  Day 6: POSTDATA has expired from cache [message #17696] Tue, 12 December 2006 02:59
esukf  is currently offline esukf
Messages: 65
Registered: December 2006
Hi all,

I've just completed day 6 and things appear to work fine except when I do a fail login and hit the browser's back and forward button, I get the POSTDATA has expired from cache warning window.

I've tested the site and it does not do this(it does on a page refresh). Is there a mistake in my code or is it something that gets resolved in a later tutorial??

[Updated on: Tue, 12 December 2006 03:08]

 Topic: I got this error on DAY1 If somebody can help
I got this error on DAY1 If somebody can help [message #17926] Thu, 14 December 2006 20:42
dmthaker  is currently offline dmthaker
Messages: 3
Registered: December 2006
Junior Member
Notice: Undefined property: sfPHPView::$actionName in /home/aum/dmtweb/newProj/cache/myapp/dev/config/modules_defa ult_config_view.yml.php on line 6

Notice: Undefined property: sfPHPView::$actionName in /home/aum/dmtweb/newProj/cache/myapp/dev/config/modules_defa ult_config_view.yml.php on line 6

Fatal error: Call to undefined method sfPHPView::getExtension() in /home/aum/dmtweb/newProj/cache/myapp/dev/config/modules_defa ult_config_view.yml.php on line 7

 Topic: problem with day2 symfony propel-crud-generate frontend question Question
problem with day2 symfony propel-crud-generate frontend question Question [message #17997] Fri, 15 December 2006 18:04
dmthaker  is currently offline dmthaker
Messages: 3
Registered: December 2006
Junior Member
I got this error on generating crud

Call to undefined method sfGenerator::getCrudColumnEditTag
stack trace

* at ()
in SF_SYMFONY_LIB_DIR/generator/sfGenerator.class.php line 129 ...
126. {
127. if (!$callable = sfMixer::getCallable('sfGenerator:'.$method))
128. {
129. throw new sfException(sprintf('Call to undefined method sfGenerator::%s', $method));
130. }
132. array_unshift($arguments, $this);
* at sfGenerator->__call('getCrudColumnEditTag', array(object('ColumnMap')))
in n/a line n/a ...
* at sfPropelCrudGenerator->getCrudColumnEditTag(object('ColumnMap'))
in /usr/local/lib/php/data/symfony/generator/sfPropelCrud/defau lt/template/templates/editSuccess.php line 16 ...
13. <?php if ($name == 'CREATED_AT' || $name == 'UPDATED_AT') continue ?>
14. <tr>
15. <th><?php echo sfInflector::humanize(sfInflector::underscore($column->getPhpName())) ?><?php if ($column->isNotNull()): ?>*<?php endif; ?>:</th>
16. <td>[?php echo <?php echo $this->getCrudColumnEditTag($column) ?> ?]</td>
17. </tr>
18. <?php endforeach; ?>
19. </tbody>
* at require('/usr/local/lib/php/data/symfony/generator/sfPropelC rud/default/template/templates/editSuccess.php')
in SF_SYMFONY_LIB_DIR/generator/sfGenerator.class.php line 60 ...
58. // eval template file
59. ob_start();
60. require($templateFile);
61. $content = ob_get_clean();
63. // replace [?php and ?]
* at sfGenerator->evalTemplate('templates/editSuccess.php')
in SF_SYMFONY_LIB_DIR/generator/sfGenerator.class.php line 47 ...
44. foreach ($templateFiles as $template)
45. {
46. // eval template file
47. $retval = $this->evalTemplate('templates/'.$template);
49. // save template file
50. $this->getGeneratorManager()->getCache()->set($template, $generatedModuleName.DIRECTORY_SEPARATOR.'templates', $retval);
* at sfGenerator->generatePhpFiles('autoQuestion', array('listSuccess.php', 'editSuccess.php', 'showSuccess.php'))
in SF_SYMFONY_LIB_DIR/lib/generator/sfPropelCrudGenerator.class .php line 85 ...
82. }
84. $this->setTheme($theme);
85. $this->generatePhpFiles($this->generatedModuleName, array('listSuccess.php', 'editSuccess.php', 'showSuccess.php'));
87. // require generated action class
88. $data = "require_once(sfConfig::get('sf_module_cache_dir').'/".$this- >generatedModuleName."/actions/actions.class.php')\n";
* at sfPropelCrudGenerator->generate(array('model_class' => 'Question', 'theme' => 'default', 'moduleName' => 'question'))
in SF_SYMFONY_LIB_DIR/generator/sfGeneratorManager.class.php line 39 ...
36. {
37. $generator = new $generator_class();
38. $generator->initialize($this);
39. $data = $generator->generate($param);
41. return $data;
42. }
* at sfGeneratorManager->generate('sfPropelCrudGenerator', array('model_class' => 'Question', 'theme' => 'default', 'moduleName' => 'question'))
in SF_SYMFONY_LIB_DIR/config/sfGeneratorConfigHandler.class.php line 72 ...
69. preg_match('#'.sfConfig::get('sf_app_module_dir_name').'/([^ /]+)/#', $configFiles[1], $match);
70. $generatorParam['moduleName'] = $match[1];
72. $data = $generatorManager->generate($config['class'], $generatorParam);
74. // compile data
75. $retval = "<?php\n".
* at sfGeneratorConfigHandler-> execute(array('/usr/local/lib/php/data/symfony/config/genera tor.yml', '/home/aum/dmtweb/askeet/apps/frontend/modules/question/conf ig/generator.yml'))
in SF_SYMFONY_LIB_DIR/config/sfConfigCache.class.php line 99 ...
96. if ($handlerToCall)
97. {
98. // call the handler and retrieve the cache data
99. $data = $handlerToCall->execute($configs);
101. $this->writeCacheFile($handler, $cache, $data);
102. }
* at sfConfigCache->callHandler('modules/question/config/generator.yml', array('/usr/local/lib/php/data/symfony/config/generator.yml' , '/home/aum/dmtweb/askeet/apps/frontend/modules/question/conf ig/generator.yml'), '/home/aum/dmtweb/askeet/cache/frontend/dev/config/modules_q uestion_config_generator.yml.php')
in SF_SYMFONY_LIB_DIR/config/sfConfigCache.class.php line 196 ...
193. if (!is_readable($cache) || $mtime > filemtime($cache))
194. {
195. // configuration has changed so we need to reparse it
196. $this->callHandler($configPath, $files, $cache);
198. // clear process cache
199. if ('config/config_handlers.yml' != $configPath)
* at sfConfigCache->checkConfig('modules/question/config/generator.yml', '1')
in SF_SYMFONY_LIB_DIR/config/sfConfigCache.class.php line 258 ...
255. */
256. public function import($config, $once = true, $optional = false)
257. {
258. $cache = $this->checkConfig($config, $optional);
260. if ($optional && !$cache)
261. {
* at sfConfigCache->import('modules/question/config/generator.yml', '1', '1')
in SF_SYMFONY_LIB_DIR/controller/sfController.class.php line 198 ...
195. }
197. // check for a module generator config file
198. sfConfigCache::getInstance()-> import(sfConfig::get('sf_app_module_dir_name').'/'.$moduleNa me.'/'.sfConfig::get('sf_app_module_config_dir_name').'/gene rator.yml', true, true);
200. if (!$this->actionExists($moduleName, $actionName))
201. {
* at sfController->forward('question', 'index')
in SF_SYMFONY_LIB_DIR/controller/sfFrontWebController.class.php line 48 ...
45. $actionName = $request->getParameter('action');
47. // make the first request
48. $this->forward($moduleName, $actionName);
49. }
50. catch (sfException $e)
51. {
* at sfFrontWebController->dispatch()
in SF_ROOT_DIR/web/frontend_dev.php line 10 ...
10. sfContext::getInstance()->getController()->dispatch();


IF anybody can resolve the issue it would be a great help
Pages (169): [1  2  3  4  5  6  7  8  9  10  11  12  13  14  15  >  »]

powered by FUDforum - copyright ©2001-2004 FUD Forum Bulletin Board Software