This forum is in READ-ONLY mode.
You can look around, but if you want to ask a new question, please use the new forum.
Home » support » symfony 1.3 and 1.4 » Unexpected resuls(set of columns) when using Doctrine_Table->find() method
icon4.gif  Unexpected resuls(set of columns) when using Doctrine_Table->find() method [message #102501] Thu, 15 July 2010 08:50 Go to previous message
fedulov.ivan  is currently offline fedulov.ivan
Messages: 2
Registered: July 2010
Junior Member
Doctrine is using inside of symfony framework with following server configuration:
php 5.2.10-2ubuntu6.4, Mysql 5.1.37-1ubuntu5, symfony 1.4.6.

The promplem is, that the same query on the same models produce diffrent results. In some cases not all columns from database table are present in generated sql query. For example: we have three columns ID, TITLE, NAME. But doctrine generates query like "SELECT t.id AS t__id, t.title AS t__title FROM..." ignoring NAME column. I tried manually add "->select(*)" in method find(line 1616 of file Table.php), and this resolves problem.

Read Message
Read Message
Previous Topic:symfony progress bar
Next Topic:can i run symfony on command window?
Goto Forum:

  

powered by FUDforum - copyright ©2001-2004 FUD Forum Bulletin Board Software