This forum is in READ-ONLY mode.
You can look around, but if you want to ask a new question, please use the new forum.
Home » legacy support » symfony 1.2 » Problem with propel:build-all (with SfGuardUser foreign keys)
icon9.gif  Problem with propel:build-all (with SfGuardUser foreign keys) [message #71210] Mon, 02 February 2009 00:06 Go to next message
samax  is currently offline samax
Messages: 18
Registered: February 2009
Junior Member
Hello,
for this afternoon, the command "symfony propel-build-all" does not work anymore with my project. I have an error every time I try to execute it.
The only things which I made before executing it are a "generate-crud", a modification of the generated forms, and finally I put attributes "not null" in certain fields of my database. And since that it doesn't working.

I tried well with a previous version of my database which worked perfectly, but that changed nothing.

Here is the result of a "propel:build-all":

>> schema    converting "E:/Programmes/wamp/...ig/generated-schema.yml" to XML
>> schema    putting E:/Programmes/wamp/www/.../generated-generated-schema.xml
>> schema    converting "E:/Programmes/wamp/...fGuardPlugin-schema.yml" to XML
>> schema    putting E:/Programmes/wamp/www/...erated-sfGuardPlugin-schema.xml
>> schema    converting "E:/Programmes/wamp/...twiki/config/schema.yml" to XML
>> schema    putting E:/Programmes/wamp/www/...iki/config/generated-schema.xml
>> schema    converting "E:/Programmes/wamp/...lugin/config/schema.yml" to XML
>> schema    putting E:/Programmes/wamp/www/...erated-sfGuardPlugin-schema.xml
>> file+     config\generated-sfGuardPlugin-schema.xml
>> file-     E:/Programmes/wamp/www/sf_proje...erated-sfGuardPlugin-schema.xml
>> propel    Running "om" phing task
Execution of target "om-template" failed for the following reason: E:\Programme
\wamp\www\sf_projetwiki\lib\symfony\lib\plugins\sfPropelPlugin\lib\vendor\prope
-generator\build-propel.xml:479:1: Duplicate table found: propel.
[phingcall] E:\Programmes\wamp\www\sf_projetwiki\lib\symfony\lib\plugins\sfProp
lPlugin\lib\vendor\propel-generator\build-propel.xml:479:1: Duplicate table fou
d: propel.
Execution of target "om" failed for the following reason: E:\Programmes\wamp\ww
\sf_projetwiki\lib\symfony\lib\plugins\sfPropelPlugin\lib\vendor\propel-generat
r\build-propel.xml:465:22: Execution of the target buildfile failed. Aborting.
    [phing] E:\Programmes\wamp\www\sf_projetwiki\lib\symfony\lib\plugins\sfProp
lPlugin\lib\vendor\propel-generator\build-propel.xml:465:22: Execution of the t
rget buildfile failed. Aborting.

  Some problems occurred when executing the task:

    build-propel.xml:479:1: Duplicate table found: propel.

    build-propel.xml:465:22: Execution of the target buildfile failed. Aborting

    Read the logs to fix them

>> file-     E:/Programmes/wamp/www/sf_proje...erated-sfGuardPlugin-schema.xml
>> file-     E:/Programmes/wamp/www/sf_proje...rdPlugin-schema-transformed.xml
>> file-     E:/Programmes/wamp/www/sf_projetwiki/config/generated-schema.xml
>> file-     E:/Programmes/wamp/www/sf_proje...enerated-schema-transformed.xml
>> file-     E:/Programmes/wamp/www/sf_proje...erated-sfGuardPlugin-schema.xml
>> file-     E:/Programmes/wamp/www/sf_proje...rdPlugin-schema-transformed.xml
>> file-     E:/Programmes/wamp/www/sf_proje.../generated-generated-schema.xml
>> file-     E:/Programmes/wamp/www/sf_proje...enerated-schema-transformed.xml


[Edit] Oh, and I looked in the log, it is empty.

Thanks for your replies.

[Updated on: Mon, 02 February 2009 12:49]

Re: Problem with propel:build-all [message #71235 is a reply to message #71210 ] Mon, 02 February 2009 12:41 Go to previous messageGo to next message
samax  is currently offline samax
Messages: 18
Registered: February 2009
Junior Member
up!
Re: Problem with propel:build-all [message #71237 is a reply to message #71210 ] Mon, 02 February 2009 12:49 Go to previous messageGo to next message
samax  is currently offline samax
Messages: 18
Registered: February 2009
Junior Member
I've new things: when I delete the foreign keys to the sf_guard_user table, it seems to work (not totally but there is changes). It's not good, I want to keep thiese relations!
Re: Problem with propel:build-all (with SfGuardUser foreign keys) [message #71410 is a reply to message #71210 ] Wed, 04 February 2009 13:05 Go to previous messageGo to next message
benlumley  is currently offline benlumley
Messages: 6
Registered: October 2008
Junior Member
Looks like you've broken your schema.yml somehow.

propel is the name of the top level node, and should appear only once I think. It looks like this is being interpreted wrongly and propel/symfony is interpreting the propel bit as a table name.
Re: Problem with propel:build-all (with SfGuardUser foreign keys) [message #71429 is a reply to message #71210 ] Wed, 04 February 2009 14:26 Go to previous messageGo to next message
samax  is currently offline samax
Messages: 18
Registered: February 2009
Junior Member
Hello,
Thank you for your reply, but I found the solution yesterday, this error appeared because I had a sf_guard_user table in Clay (which I use for the database modelling) for the relations with my tables, and I forgot to delete it after the conversion into yml.

[Updated on: Wed, 04 February 2009 14:27]

Re: Problem with propel:build-all (with SfGuardUser foreign keys) [message #72634 is a reply to message #71210 ] Tue, 17 February 2009 04:02 Go to previous messageGo to next message
zven  is currently offline zven
Messages: 6
Registered: August 2007
Location: Aachen, Germany
Junior Member
Hi, i don't want to open a new thread with the same problem, so:
Does a automatic solution for the problem exist, to avoid the typical "Duplicate table found: propel" error if you want to use the phing reverse engineering with the "propel:build-schema" command and you have tables of plugins (sfGuardUser, ...) in your database mixed with your own tables? I don't want to delete the tables from the schema.yml manually to avoid this error.

Thanks, Sven


WapplerSystems
http://www.wapplersystems.de
Re: Problem with propel:build-all (with SfGuardUser foreign keys) [message #99010 is a reply to message #72634 ] Thu, 13 May 2010 17:37 Go to previous messageGo to next message
mrossw  is currently offline mrossw
Messages: 3
Registered: May 2010
Location: South America
Junior Member
zven wrote on Tue, 17 February 2009 00:02

Hi, i don't want to open a new thread with the same problem, so:
Does a automatic solution for the problem exist, to avoid the typical "Duplicate table found: propel" error if you want to use the phing reverse engineering with the "propel:build-schema" command and you have tables of plugins (sfGuardUser, ...) in your database mixed with your own tables? I don't want to delete the tables from the schema.yml manually to avoid this error.

Thanks, Sven


Hey Sven did you get an answer to this question ? I am just running into the same dilema and about to do some manual grunt work ...

Thanks.
M.
Re: Problem with propel:build-all (with SfGuardUser foreign keys) [message #99013 is a reply to message #71210 ] Thu, 13 May 2010 18:19 Go to previous messageGo to next message
halfer  is currently offline halfer
Messages: 9535
Registered: January 2006
Location: West Midlands, UK
Faithful Member
Try deleting all automatically generated "/config/generated-schema*" files from your project.


Remember Palestine
Re: Problem with propel:build-all (with SfGuardUser foreign keys) [message #99051 is a reply to message #99010 ] Fri, 14 May 2010 12:05 Go to previous message
zven  is currently offline zven
Messages: 6
Registered: August 2007
Location: Aachen, Germany
Junior Member
mrossw wrote on Thu, 13 May 2010 17:37

Hey Sven did you get an answer to this question ? I am just running into the same dilema and about to do some manual grunt work ...

Thanks.
M.


Here my blog entry with solution for this problem: http://www.wapplersystems.de/blog/symfony-propel-duplicate-t able-found-propel/


WapplerSystems
http://www.wapplersystems.de
Previous Topic:Routing problem
Next Topic:Pagination
Goto Forum:
  

powered by FUDforum - copyright ©2001-2004 FUD Forum Bulletin Board Software