This forum is in READ-ONLY mode.
You can look around, but if you want to ask a new question, please use the new forum.
Home » legacy support » symfony 1.1 » Another Model Issue
Another Model Issue [message #98463] Tue, 04 May 2010 01:41
byuhobbes  is currently offline byuhobbes
Messages: 15
Registered: June 2009
Location: Utah, USA
Junior Member
I'm creating a web app using symfony 1.1.9 and I'm running into a problem with my models. Early in development, I changed the name of one of my models from SfGuardPiProfile to SfGuardUserPiProfile. Ever since, I've been using the SfGuardUserPiProfile.

I'm close to finishing the web app, so I'm trying to figure out how the propel:data-dump task works so I can set up daily and weekly DB backups. When I ran the command

symfony propel:data-dump frontend

I got an error saying that the sf_guard_pi_profile table does not exist in my database. I was surprised to see that message, since that model has not been in my schema.yml file for a long time. I looked in the lib/model directory, however, and sure enough, PHP model files are there for both the old and the new models.

I tried moving the old files to a different directory, running the propel:build-all-load task, clearing the cache, and then running the data dump task again. However, that time I got a fatal error saying it could not find the SfGuardPiProfile.php class.

Why does symfony thinks it needs this file? It doesn't create a MySQL table for it, and it is not in the config.yml file? However, each time I rebuild my models these classes are rebuilt as well. Any ideas?


Previous Topic:Model Build Problem
Next Topic:web_debug invisible en v1.1
Goto Forum:

powered by FUDforum - copyright ©2001-2004 FUD Forum Bulletin Board Software