This forum is in READ-ONLY mode.
You can look around, but if you want to ask a new question, please use the new forum.
Home » legacy support » symfony 1.1 » Model Build Problem
Model Build Problem [message #97399] Thu, 15 April 2010 01:08 Go to next message
byuhobbes  is currently offline byuhobbes
Messages: 15
Registered: June 2009
Location: Utah, USA
Junior Member
So, I've encountered a strange error. I've been working with the same schema for several months now, but today I updated it and added a new data model. I ran the 'propel:build-all' task and cleared the cache, but unfortunately the PHP class wasn't created for this new model in the 'lib/model' directory. I didn't see any errors in the command line output, and the MySQL table was created properly, just no PHP class.

I've looked around on the forums but I can't find anything like this. Any ideas?

FYI I'm running syfmony 1.1.9 out of my user directory on a Debian system.


</byuhobbes>
Re: Model Build Problem [message #97752 is a reply to message #97399 ] Wed, 21 April 2010 12:15 Go to previous messageGo to next message
halfer  is currently offline halfer
Messages: 9535
Registered: January 2006
Location: West Midlands, UK
Faithful Member
Not sure. Are there any errors when you execute the command? Anything in your PHP logs?


Remember Palestine
Re: Model Build Problem [message #98443 is a reply to message #97399 ] Mon, 03 May 2010 15:45 Go to previous message
byuhobbes  is currently offline byuhobbes
Messages: 15
Registered: June 2009
Location: Utah, USA
Junior Member
Turned out it was a problem with longvarchar and CreoleTypes.php http://forum.symfony-project.org/index.php/m/96525/. Apparently the entire propel:build-model task was failing. I didn't see the error in my CLI output, and I couldn't tell because all of the rest of my models were working fine.

I edited the CreoleTypes.php file and everything is working fine now. Thanks!


</byuhobbes>
Previous Topic:session time out
Next Topic:Another Model Issue
Goto Forum:
  

powered by FUDforum - copyright ©2001-2004 FUD Forum Bulletin Board Software