This forum is in READ-ONLY mode.
You can look around, but if you want to ask a new question, please use the new forum.
Home » support » Symfony 2.0 » [Resolved] Php version required is 5.3.1 Ôo (ubuntu's version is 5.2.10)
[Resolved] Php version required is 5.3.1 Ôo (ubuntu's version is 5.2.10) [message #97903] Thu, 22 April 2010 21:02 Go to next message
DdOo  is currently offline DdOo
Messages: 2
Registered: April 2010
Junior Member
Hello,

I'm surprised to see php version required is 5.3.1 Oô mine is 5.2.10 because of I use Ubuntu... (Karmic). Rolling Eyes

The majority of php framework/scripts/CMS/... i know required at most php5... Wink .

Thanks Wink .

[Updated on: Fri, 23 April 2010 15:27]

Re: Php version required is 5.3.1 Ôo (ubuntu's version is 5.2.10) [message #97909 is a reply to message #97903 ] Thu, 22 April 2010 21:31 Go to previous messageGo to next message
Yannick Mortier  is currently offline Yannick Mortier
Messages: 2
Registered: April 2010
Location: Germany, Rhineland-Palati...
Junior Member

That is quite intentional as it is written on the homepage of Symfony 2. It's because Symfony 2 uses Namespaces which is a feature of PHP 5.3

In the next release of Ubuntu (which will be a LTS) there will be PHP 5.3 so don't worry.

I guess when Symfony 2 is finally released 5.3 will be the standard in any current Linux distribution.
Re: Php version required is 5.3.1 Ôo (ubuntu's version is 5.2.10) [message #97934 is a reply to message #97903 ] Fri, 23 April 2010 13:03 Go to previous messageGo to next message
clac  is currently offline clac
Messages: 4
Registered: April 2010
Junior Member
You can install php5.3 yourself.
I did it, following this tutorial:
http://www.brandonsavage.net/installing-php-5-3-on-ubuntu/

[Updated on: Fri, 23 April 2010 13:03]

Re: Php version required is 5.3.1 Ôo (ubuntu's version is 5.2.10) [message #97952 is a reply to message #97903 ] Fri, 23 April 2010 15:26 Go to previous messageGo to next message
DdOo  is currently offline DdOo
Messages: 2
Registered: April 2010
Junior Member
Thanks for the answers :

@Yannick Mortier : it's not written on the homepage...

@clac @Yannick Mortier : I will wait (one week Wink ) for Ubuntu 10.04 Wink (it's just for a personnal project Wink ).
Re: [Resolved] Php version required is 5.3.1 Ôo (ubuntu's version is 5.2.10) [message #97953 is a reply to message #97903 ] Fri, 23 April 2010 15:33 Go to previous message
halfer  is currently offline halfer
Messages: 9535
Registered: January 2006
Location: West Midlands, UK
Faithful Member
DdOo wrote on Thu, 22 April 2010 20:02

Hello,

I'm surprised to see php version required is 5.3.1 Oô mine is 5.2.10 because of I use Ubuntu... (Karmic). Rolling Eyes

The majority of php framework/scripts/CMS/... i know required at most php5... Wink .

Thanks Wink .

I've seen it suggested that some folks regard PHP 5.0 as alpha quality and 5.1 as beta. I'd not run anything requiring 5.0 on anything less than 5.2 these days.

Pleased to hear that Ubuntu is keeping up-to-date, am looking forward to trying their new LTS version when it is released. However us RHEL users will just have to keep installing a decent version of PHP manually - AFAIK they're still stuck on 5.1.6!


Remember Palestine
Previous Topic:Session problem when created in a subfolder
Next Topic:Symfony 2.0 CMS - Ideas
Goto Forum:
  

powered by FUDforum - copyright ©2001-2004 FUD Forum Bulletin Board Software