This forum is in READ-ONLY mode.
You can look around, but if you want to ask a new question, please use the new forum.
Home » support » Installation and setup » [[ ERROR ]] PHP version is at least 5.2.4: FAILED
[[ ERROR ]] PHP version is at least 5.2.4: FAILED [message #80591] Wed, 24 June 2009 18:27 Go to next message
phbord  is currently offline phbord
Messages: 16
Registered: February 2009
Junior Member
hello,

when I write "php lib/vendor/symfony/data/bin/check_configuration.php" on the terminal, here is the result :
********************************
*                              *
*  symfony requirements check  *
*                              *
********************************

php.ini used by PHP: WARNING: not using a php.ini file

** WARNING **
*  The PHP CLI can use a different php.ini file
*  than the one used with your web server.
*  If this is the case, please launch this
*  utility from your web server.
** WARNING **

** Mandatory requirements **

[[ ERROR ]] PHP version is at least 5.2.4: FAILED
            *** Current version is 4.4.9 ***
You must fix this problem before resuming the check.

why ?
so, it'S impossible to create the project...
Re: [[ ERROR ]] PHP version is at least 5.2.4: FAILED [message #80595 is a reply to message #80591 ] Wed, 24 June 2009 18:53 Go to previous messageGo to next message
Russ  is currently offline Russ
Messages: 413
Registered: August 2008
Location: Oslo, Norway
Faithful Member

Yes, unfortunately you must be running PHP 5 to use symfony, and really you should be running PHP 5.2 anyway Smile


*On Freenode I am rooster*
http://www.walkandclimb.co.uk/images/monkeydust.jpghttp://www.walkandclimb.co.uk/userpix/2_linux_wave_small_2.jpg
Re: [[ ERROR ]] PHP version is at least 5.2.4: FAILED [message #80661 is a reply to message #80591 ] Thu, 25 June 2009 13:12 Go to previous messageGo to next message
halfer  is currently offline halfer
Messages: 9535
Registered: January 2006
Location: West Midlands, UK
Faithful Member
Bear in mind you may have PHP5, but that PHP4 is the default binary on your system. Do you know what you have installed on your machine/host?


Remember Palestine
Re: [[ ERROR ]] PHP version is at least 5.2.4: FAILED [message #80692 is a reply to message #80661 ] Thu, 25 June 2009 17:46 Go to previous messageGo to next message
phbord  is currently offline phbord
Messages: 16
Registered: February 2009
Junior Member
I've installed MAMP on MAC OSX an PHP5.
here's the result with phpinfo on MAMP : PHP Version 5.2.6
I think PHP version (check configuration) is actived on Apache of system and is disactived on MAMP.
So, I've disactived "share personnal web" on preferences, share and firewall.
I've created and actived a new parameter "apache2" on preferences, sfirewall, with TCP ports number : 80, 427 and port's name : Other.

here's I wrote on host file :
127.0.0.1	localhost
255.255.255.255	broadcasthost
::1             localhost

# AJOUT DE CODE POUR SYMFONY :
127.0.0.1    jobeet.localhost
127.0.0.1    phbord.localhost
127.0.0.1    betterworkout.localhost


What do you thing ?
I don't know to activate "check configuration" on MAMP.
Re: [[ ERROR ]] PHP version is at least 5.2.4: FAILED [message #80693 is a reply to message #80591 ] Thu, 25 June 2009 17:55 Go to previous messageGo to next message
halfer  is currently offline halfer
Messages: 9535
Registered: January 2006
Location: West Midlands, UK
Faithful Member
I don't know Mamp or Macs, but what does "php -v" give you? If it comes back with PHP4, try looking for that binary, rename it and create a symlink of the same name to your PHP5 binary. (This will break any PHP4 software you are running on the same machine, so you'll have to take a different approach if you want to run both versions side-by-side).


Remember Palestine
Re: [[ ERROR ]] PHP version is at least 5.2.4: FAILED [message #80694 is a reply to message #80693 ] Thu, 25 June 2009 18:00 Go to previous messageGo to next message
phbord  is currently offline phbord
Messages: 16
Registered: February 2009
Junior Member
Here's the result with "php -v" :
PHP 4.4.9 (cli) (built: Sep 17 2008 16:31:15)
Copyright (c) 1997-2008 The PHP Group
Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies


what is it "binary" an "symlink" ?
Re: [[ ERROR ]] PHP version is at least 5.2.4: FAILED [message #80697 is a reply to message #80591 ] Thu, 25 June 2009 18:36 Go to previous messageGo to next message
halfer  is currently offline halfer
Messages: 9535
Registered: January 2006
Location: West Midlands, UK
Faithful Member
A binary is an executable file, and a symlink is a pointer file to a real file. Try this:

which php

When it comes back, do ls -l on it, e.g.:

ls -a /usr/bin/php

And provide the results here.


Remember Palestine
Re: [[ ERROR ]] PHP version is at least 5.2.4: FAILED [message #80698 is a reply to message #80591 ] Thu, 25 June 2009 18:37 Go to previous message
halfer  is currently offline halfer
Messages: 9535
Registered: January 2006
Location: West Midlands, UK
Faithful Member
(If you are completely unfamilar with the command line, you might try uninstalling PHP4 and reinstalling Mamp - as understanding this stuff is not something that happens in five minutes!)


Remember Palestine
Previous Topic:No images on first run, no "sf" dir
Next Topic:SQL-Server data-type mismatch error using ODBC driver
Goto Forum:
  

powered by FUDforum - copyright ©2001-2004 FUD Forum Bulletin Board Software