This forum is in READ-ONLY mode.
You can look around, but if you want to ask a new question, please use the new forum.
Home » support » Installation and setup » No images on first run, no "sf" dir
No images on first run, no "sf" dir [message #80503] Tue, 23 June 2009 21:28 Go to next message
n1313  is currently offline n1313
Messages: 5
Registered: June 2009
Junior Member
Hello.

I'm a newbie, and today I finally managed to run symfony, yay. New problem: I don't have any images on my "Congratulations! You have successfully created your symfony project." page. The links point to /sf directory, and there is no such thing in my installation.

I looked for hints in this forum, but all the solutions suggest that I need to create an alias for this folder pointing to somewhere else, like "C:\php5\pear\data\symfony\web\sf" or something. But I just do not have this "sf" dir, even in that "somewhere else" location.

I am on Windows and installed Symfony from PEAR. This is the path to symfony: D:\Web\usr\local\php5\PEAR\symfony, there is no /web or /sf directory. The project is located in D:\Web\home\sy\web. There is no /sf directory either. Did I miss something during installation?

Thanks.
Re: No images on first run, no "sf" dir [message #80504 is a reply to message #80503 ] Tue, 23 June 2009 21:37 Go to previous messageGo to next message
Russ  is currently offline Russ
Messages: 413
Registered: August 2008
Location: Oslo, Norway
Faithful Member

Try: D:\Web\usr\local\php5\PEAR\symfony\data\web\sf


*On Freenode I am rooster*
http://www.walkandclimb.co.uk/images/monkeydust.jpghttp://www.walkandclimb.co.uk/userpix/2_linux_wave_small_2.jpg
Re: No images on first run, no "sf" dir [message #80601 is a reply to message #80503 ] Wed, 24 June 2009 19:13 Go to previous messageGo to next message
n1313  is currently offline n1313
Messages: 5
Registered: June 2009
Junior Member
Unfortunately, there is no /data folder in my symfony installation (D:\Web\usr\local\php5\PEAR\symfony). There are: /action /addon /autoload /cache /command /config /controller /database /debug /event /exception /filter /form /generator /helper /i18n list /log /plugin /plugins /request /response /routing /storage /task /test /user /util /validator /vendor /view /widget /yaml



[Updated on: Wed, 24 June 2009 19:18]

Re: No images on first run, no "sf" dir [message #80603 is a reply to message #80601 ] Wed, 24 June 2009 19:16 Go to previous messageGo to next message
Russ  is currently offline Russ
Messages: 413
Registered: August 2008
Location: Oslo, Norway
Faithful Member

Very strange... oh well, don't worry about it - download the files you need and drop them where you need them Smile

http://www.symfony-project.org/installation


*On Freenode I am rooster*
http://www.walkandclimb.co.uk/images/monkeydust.jpghttp://www.walkandclimb.co.uk/userpix/2_linux_wave_small_2.jpg
Re: No images on first run, no "sf" dir [message #80604 is a reply to message #80503 ] Wed, 24 June 2009 19:20 Go to previous messageGo to next message
n1313  is currently offline n1313
Messages: 5
Registered: June 2009
Junior Member
Hmm, okay, thanks, I will. But I am confused: why symfony that comes from PEAR differs so much from downloadable symfony? The directory structure is VERY different.
Re: No images on first run, no "sf" dir [message #80605 is a reply to message #80604 ] Wed, 24 June 2009 19:27 Go to previous messageGo to next message
Russ  is currently offline Russ
Messages: 413
Registered: August 2008
Location: Oslo, Norway
Faithful Member

PEAR gives you a "system" installation of symfony, so is ok if you only have one instance of symfony on your machine.

If you ever want to have more than one symfony installation (like when 1.3 comes out you might still want to use 1.2 with your old projects) then PEAR is not the best solution.


*On Freenode I am rooster*
http://www.walkandclimb.co.uk/images/monkeydust.jpghttp://www.walkandclimb.co.uk/userpix/2_linux_wave_small_2.jpg
Re: No images on first run, no "sf" dir [message #80606 is a reply to message #80503 ] Wed, 24 June 2009 19:28 Go to previous messageGo to next message
n1313  is currently offline n1313
Messages: 5
Registered: June 2009
Junior Member
I am comparing my pear install with downloaded package and it seems that I have only /lib directory, not the entire product. Why? Should I bother?

[Updated on: Wed, 24 June 2009 19:29]

Re: No images on first run, no "sf" dir [message #80607 is a reply to message #80606 ] Wed, 24 June 2009 20:55 Go to previous messageGo to next message
Russ  is currently offline Russ
Messages: 413
Registered: August 2008
Location: Oslo, Norway
Faithful Member

I'll be honest and say I really don't know the score with the PEAR package. My first symfony project used PEAR, but then I scrapped it as soon as I needed to develop a new project in 1.1 whilst maintaining another 1.0 version...


*On Freenode I am rooster*
http://www.walkandclimb.co.uk/images/monkeydust.jpghttp://www.walkandclimb.co.uk/userpix/2_linux_wave_small_2.jpg
Re: No images on first run, no "sf" dir [message #80609 is a reply to message #80607 ] Wed, 24 June 2009 21:04 Go to previous messageGo to next message
n1313  is currently offline n1313
Messages: 5
Registered: June 2009
Junior Member
Okay, thanks for your help. :)
Re: No images on first run, no "sf" dir [message #80649 is a reply to message #80503 ] Thu, 25 June 2009 08:46 Go to previous message
cokker  is currently offline cokker
Messages: 582
Registered: January 2007
Location: Germany
Faithful Member
pear packages comes with lib and data dir, but on different locations. (don't know exactly the path) Try a search for it.
(the executable is located inside the data dir)

greets
Sven
Previous Topic:Keeping the production database password secret
Next Topic:[[ ERROR ]] PHP version is at least 5.2.4: FAILED
Goto Forum:
  

powered by FUDforum - copyright ©2001-2004 FUD Forum Bulletin Board Software