This forum is in READ-ONLY mode.
You can look around, but if you want to ask a new question, please use the new forum.
Home » symfony projects » askeet » Day 4 : timeout with load_data.php
Day 4 : timeout with load_data.php [message #5271] Thu, 20 April 2006 23:18
demental  is currently offline demental
Messages: 34
Registered: April 2006
Location: tarn
Member
Hi

This tutorial is just great !

But I'm stuck with transactions in the day 4.

When I
php load_data.php


after adding transaction handling in interests and relevancy save() methods, I have this error :

Fatal error: Uncaught exception 'PropelException' with message 'Unable to execute INSERT statement. [wrapped: Could not execute update [Native Error: Lock wait timeout exceeded; try restarting transaction] [User Info: INSERT INTO ask_interest (QUESTION_ID,USER_ID,CREATED_AT) VALUES (16,29,'2006-04-20 23:09:22')]]' in /Applications/MAMP/bin/php5/lib/php/symfony/vendor/propel/util/BasePeer.php:308
Stack trace:
#0 /Library/WebServer/Documents/symfony_proj/askeet/lib/model/om/BaseInterestPeer.php(904): BasePeer::doInsert(Object(Criteria), Object(sfDebugConnection))
#1 /Library/WebServer/Documents/symfony_proj/askeet/lib/model/om/BaseInterest.php(334): BaseInterestPeer::doInsert(Object(Interest), Object(sfDebugConnection))
#2 /Library/WebServer/Documents/symfony_proj/askeet/lib/model/om/BaseInterest.php(284): BaseInterest->doSave(Object(sfDebugConnection))
#3 /Library/WebServer/Documents/symfony_proj/askeet/lib/model/Interest.php(27): BaseInterest->save(Object(sfDebugConnection))
#4 /Applications/MAMP/bin/php5/lib/php/symfony/ in /Applications/MAMP/bin/php5/lib/php/symfony/vendor/propel/util/BasePeer.php on line 308


This is quite surprising as I don't see where any of the queries sent to the database when inserting and interest or a relevancy need to wait for another to be commited, as :

- The transaction begins
- the interest row is saved
- the question row is read
- the question row is updated
- the transaction is commited

When I switch back to basic save, without transaction, it works ok...

Have someone had the same pb and found a workaround ?
Previous Topic:Problem in getting email in HTML format
Next Topic:[resolved] Get svn code
Goto Forum:
  

powered by FUDforum - copyright ©2001-2004 FUD Forum Bulletin Board Software