This forum is in READ-ONLY mode.
You can look around, but if you want to ask a new question, please use the new forum.
Home » symfony projects » askeet » Build-SQL Problem
Build-SQL Problem [message #2307] Wed, 01 February 2006 10:56
rawneus  is currently offline rawneus
Messages: 1
Registered: February 2006
Location: Raleigh, NC
Junior Member
I installed WAMP5 on my local XP box to test out various frameworks for my linux production server, Symfony is one of many, and thus far is looking extremely promising.

The tutorials are all aimed mostly for linux, though, so I've had to wage some battles to get some things to work. I'm also double dosing on the learning with the Subversioning system, very nice touch.

On Day 2 I ran into a problem with build-sql. I copied symfony.bat into my Askeet project folder and edited it to hardcore the path back to its home path so that it would work and I could still run it from the project directory. Every command thus far has worked fine except build-sql. For some reason, it tries to find the schema.xml file in

i:\php\config

instead of the config folder under the project folder.


Can anyone explain why or what I can do to fix this? I really want to get into the meat of this framework but things like this are starting to get aggravating. :\

Thanks,

Jason

OUTPUT
-------

D:\SVN\askeet\trunk>symfony build-sql
Buildfile: I:\wamp\php\PEAR\data\symfony\bin\build.xml

sf > build-sql:
[phing] Calling Buildfile 'I:\wamp\php\pear\symfony\propel-generator\build.x
ml' with target 'sql'

propel-project-builder > projectcheck:

propel-project-builder > configure:
[echo] Loading project-specific props from D:\SVN\askeet\trunk/config/build
.properties

propel-project-builder > sql:
[phing] Calling Buildfile 'I:\wamp\php\pear\symfony\propel-generator\build-p
ropel.xml' with target 'sql'

propel > check-run-only-on-schema-change:

propel > sql-check:

propel > sql:
[echo] +------------------------------------------+
[echo] | |
[echo] | Generating SQL for YOUR Propel project! |
[echo] | |
[echo] +------------------------------------------+
[phingcall] Calling Buildfile 'I:\wamp\php\pear\symfony\propel-generator\build-p
ropel.xml' with target 'sql-template'

propel > sql-template:
Execution of target "sql-template" failed for the following reason: I:\wamp\php\
pear\symfony\propel-generator\build-propel.xml:150:1: Directory I:\wamp\php\conf
ig not found.
[phingcall] I:\wamp\php\pear\symfony\propel-generator\build-propel.xml:1 50:1: Di
rectory I:\wamp\php\config not found.

BUILD FINISHED

Total time: 1.8019 second
Previous Topic:Day 4 pushed things (my brain) a bit...
Next Topic:Day 7 - Too many forwards have been detected for this request
Goto Forum:
  

powered by FUDforum - copyright ©2001-2004 FUD Forum Bulletin Board Software