This forum is in READ-ONLY mode.
You can look around, but if you want to ask a new question, please use the new forum.
Home » support » symfony 1.3 and 1.4 » symfony 1.4 and ssl
symfony 1.4 and ssl [message #103279] Fri, 30 July 2010 11:09 Go to next message
alme  is currently offline alme
Messages: 2
Registered: July 2010
Junior Member
Hi,
how i filter a module or action with https protocol in symfony 1.4?
Normally i use different actions in different scripts and i can use mod_rewrite. In symfony framework i use different actions in only one module, so i can't use mod rewrite for this. I need set option in routing.yml.

sfSslRequirementPlugin is not efficient for this symfony version.

thank you
Re: symfony 1.4 and ssl [message #103281 is a reply to message #103279 ] Fri, 30 July 2010 11:34 Go to previous messageGo to next message
halfer  is currently offline halfer
Messages: 9535
Registered: January 2006
Location: West Midlands, UK
Faithful Member
It's sfSslRequirementPlugin you need, though I am not sure if it's been updated for 1.4. I don't know what you mean about it being "not efficient for this version" - do you mean "not suitable"?

Edit: even if it is the wrong version, try installing it, and then modify it accordingly - if you are comfortable with symfony generally, that is!

[Updated on: Fri, 30 July 2010 11:35]


Remember Palestine
Re: symfony 1.4 and ssl [message #103326 is a reply to message #103281 ] Fri, 30 July 2010 21:41 Go to previous messageGo to next message
alme  is currently offline alme
Messages: 2
Registered: July 2010
Junior Member
Do you use sfSslRequirementPlugin 2.0 with Symfony 1.4?

I'm learning Symfony from 4 days. If i install sfSslRequirementPlugin by symfony task i have this error:

php symfony plugin:install sfSslRequirementPlugin
>> plugin installing plugin "sfSslRequirementPlugin"


No release available for plugin "sfSslRequirementPlugin"


php symfony plugin:install symfony/sfSslRequirementPlugin
>> plugin installing plugin "symfony/sfSslRequirementPlugin"


The channel "symfony" does not support the REST protocol

If i use the package ( http://plugins.symfony-project.org/get/sfSslRequirementPlugi n/sfSslRequirementPlugin-2.0.0.tgz), class is loaded but there isn't redirect and i can't see (in php) values actions object/array i defined in secuity.yml

Re: symfony 1.4 and ssl [message #103353 is a reply to message #103279 ] Sat, 31 July 2010 15:31 Go to previous message
halfer  is currently offline halfer
Messages: 9535
Registered: January 2006
Location: West Midlands, UK
Faithful Member
Try downloading it from the plugins location you've linked to, and unpack the plugin folder in situ without all the PEAR commands. Clear your cache and follow any settings configuration as per the docs.

No, I have not used this plugin (edit: not the 1.3/1.4 version - I have used the 1.0 version, and it seemed to work fine).

[Updated on: Sat, 31 July 2010 15:32]


Remember Palestine
Previous Topic:Pure M:N Form
Next Topic:Best procedure for including files based on configuration settings
Goto Forum:
  

powered by FUDforum - copyright ©2001-2004 FUD Forum Bulletin Board Software