This forum is in READ-ONLY mode.
You can look around, but if you want to ask a new question, please use the new forum.
Home » legacy support » symfony 1.0 » some sql fields are not set.
some sql fields are not set. [message #103334] Sat, 31 July 2010 02:52 Go to next message
guyensymfony  is currently offline guyensymfony
Messages: 31
Registered: May 2009
Member
Guys, I use following to load my data into database.

$databaseManager = new sfDatabaseManager();
$databaseManager->initialize();
$data = new sfPropelData();
$data->setDeleteCurrentData(true);
$data-> loadData(sfConfig::get('sf_data_dir').DIRECTORY_SEPARATOR.'m ainData');
$data-> loadData(sfConfig::get('sf_data_dir').DIRECTORY_SEPARATOR.'c ardData');
$this->setFlash('msg', 'Done loading main and card data...');
$this->redirect('admin/database');

Now in lib/model folder I have a businessCard class with save() function overridden as follows:

class BusinessCard extends BaseBusinessCard
{
public function save($con = null)
{
$ret = parent::save($con);
$this->setXmlFileName('card'. $this->getFileIndex(). '.xml');
$this->setBackground('background'. $this->getFileIndex(). '.jpg');
$this->setXmlFileName('card'. $this->getFileIndex(). '.xml');
$ret = parent::save($con);
return $ret;
}
}

Now if I load it locally then xmlFileName and Background fields are filled appropriately.

With exact same code, uploaded to the server, those fields are somehow not being filled because save() function is definitely not being callled. Can someone give me a hint. Thanks!

[Updated on: Sat, 31 July 2010 02:52]

Re: some sql fields are not set. [message #103388 is a reply to message #103334 ] Mon, 02 August 2010 06:53 Go to previous message
guyensymfony  is currently offline guyensymfony
Messages: 31
Registered: May 2009
Member
no one can give a hint??? cant believe it.
Previous Topic:Give me more example
Next Topic:Different dates by Symfony Peer classes and MySQL
Goto Forum:
  

powered by FUDforum - copyright ©2001-2004 FUD Forum Bulletin Board Software