This forum is in READ-ONLY mode.
You can look around, but if you want to ask a new question, please use the new forum.
Home » support » symfony 1.3 and 1.4 » [SOLVED]sfForkedDoctrineApplyPlugin new Installations problems
[SOLVED]sfForkedDoctrineApplyPlugin new Installations problems [message #103087] Mon, 26 July 2010 15:08 Go to next message
atentaten  is currently offline atentaten
Messages: 44
Registered: April 2008
Member
Anyone tried installing sfForkedDoctrineApplyPlugin recently.

Not too long ago the plugin installed fine via:
symfony plugin:install sfForkedDoctrineApplyPlugin


Now the the installer is throwing this error:
Unable to install plugin "sfForkedDoctrineApplyPlugin" (version  >= 4.0.0 <= 4.9.9 exclude 4.9.9) because it depends on plugin "sfDoctrineGuardPlugin" which is not installed (install dependencies by hand or use the --install_deps option for automatic installation).


I know that sfDoctrineGuard is configured and installed.

So, I installed sfForkedDoctrineApply manually, but for some reason it seems as if the module/actions for the plugin are not being recognized. For example, if I try: ..frontend_dev.php/user/new
I get: Action "sfApply/apply" does not exist. However, the routes are there in my routing.yml.

I have the plugin configured in my projectConfiguration.class.php, also I have the appropriate modules (sfApply) enabled in settings.yml.

I just found out that this plugin was upgraded this month.
Any ideas?

[Updated on: Tue, 27 July 2010 17:41]

Re: sfForkedDoctrineApplyPlugin new Installations problems [message #103090 is a reply to message #103087 ] Mon, 26 July 2010 15:46 Go to previous messageGo to next message
anxious  is currently offline anxious
Messages: 38
Registered: June 2010
Location: France
Member
you have the version 5.0.0 of sfDoctrineGuardAuth and it's not compatible.

sfForked has been updated to avoid to install version 5.0.0 of guard auth, but this version v.3.1.2 is broken, it will end with an error like me :

http://groups.google.com/group/symfony-users/browse_thread/t hread/57b1a06476ed4850


The best combinaison to get this working is (until they fixed the problems but i don't know how to contact the author of sfForked) :

Install manually sfDoctrineGuardAuth < 5.0.0
Install sfForked....... = 1.3.0
[SOLVED]Re: sfForkedDoctrineApplyPlugin new Installations problems [message #103127 is a reply to message #103090 ] Tue, 27 July 2010 14:19 Go to previous message
atentaten  is currently offline atentaten
Messages: 44
Registered: April 2008
Member
This works. Thank you, sir.
Previous Topic:Unset embedded form before validation happens [SOLVED]
Next Topic:Lock access to /sf_guard_user to non admin users
Goto Forum:
  

powered by FUDforum - copyright ©2001-2004 FUD Forum Bulletin Board Software