This forum is in READ-ONLY mode.
You can look around, but if you want to ask a new question, please use the new forum.
Home » support » Installation and setup » 1.2 | Autoload file found, Autoload class not found.
1.2 | Autoload file found, Autoload class not found. [message #102276] Fri, 09 July 2010 19:18
pepsi  is currently offline pepsi
Messages: 1
Registered: July 2010
Junior Member

I have been searching the forums about some of the problems with configuration file. I changed the slashes of the autoload path, but still it does not work.

The error i get is:
Fatal error: Class 'sfCoreAutoload' not found in
/var/home/{something ;)}/config/ProjectConfiguration.class.php on line 4.

This is the require_once path.
require_once dirname(__FILE__).'/../lib/vendor/symfony/lib/autoload/sfCoreAutoload.class.php';

The path seems to be correct since i tested it with is_file() method and it return true.
Yet it goes wrong when we get here:


Also tested to include some of my own classes in my lib folder, that worked withought any problems.

So if anyone could help me further with solving this problem it would be greatly aprreciated.

Best Regards

require_once dirname(__FILE__).'/../lib/vendor/symfony/lib/autoload/sfCoreAutoload.class.php';


class ProjectConfiguration extends sfProjectConfiguration
  public function setup()
    // for compatibility / remove and enable only the plugins you want

    $this->enableAllPluginsExcept(array('sfDoctrinePlugin', 'sfCompat10Plugin'));

Symfony Version 1.2 / Propel
PHP 5.2.13

PS: If more information is needed please let me know.
Previous Topic:how to find in windows php.exe....?
Next Topic:Cache directory problem, uncaught exception sfCacheException, tried everything nothing works
Goto Forum:

powered by FUDforum - copyright ©2001-2004 FUD Forum Bulletin Board Software